Optiplex Desktops

Last reply by 01-29-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
27641

Blue screen after installing SupportAssist

After working in my new IT department for the last six months, I've been encouraging the install of Dell SupportAssist on our Windows 10 machines, to ensure that the drivers are regularly updated and the systems monitored.

However, over the summer, we had a user who was getting very frequent blue screening.  Dell provided warranty support and replaced the logic board.  But the system continued to blue screen.  After wiping the system repeatedly, we finally started making the connection to the blue screen and Dell Support Assist.

The issue is now 100% repeatable.  When the system is running Windows 10 1803 or older, Dell Support Assist runs normally, no blue screening.  When the system is upgraded to Windows 10 1809 or 1903, the blue screening occurs within minutes of boot and the machine is virtually unusable, except for a few minutes at a time.  

However, this only occurs on certain models of Dells.  We have probably 50 computers with Dell Support Assist installed, fully updated to Windows 10 1903 and we've seen this same behavior on about four of them.  One is an XPS, another is an Optiplex 7040, and the rest I can't recall off the top of my head.  We simply uninstall Dell Support Assist and blue screening stops and computer operates normally.

I explained all of this to Dell and they wanted to replace the logic board again.  They really need to focus on their application instead of throwing parts at a computer.

Solution (1)

Accepted Solutions
29778

@mrgintautas @donm4599x we have found the issue to be caused by an incompatibility with the Intel RST driver. Our recommendation to resolve this issue is to run Support Assist on the system to ensure that the system finds the latest drivers and installs them.

Once done - uninstall Support Assist from the system.

Manually update the latest iRST driver on the system - more info on how to do this can be found here under "Resolution Steps"

If that fails to resolve the issue it is recommended to manually install the iRST driver instead.

Unzip the latest iRST driver for your notebook. Navigate to Windows 10 device manager and locate the Storage Controller. Select the controller that has Intel in it's name. Right click "Update Driver", select driver manually from the drive and navigate to the folder where you extracted the iRST driver too. Choose the Windows 10 folder and select Ok. Once it installs, reboot the system. 

Now install Support Assist and then system should no longer bluescreen.

That article I also provided a link to also explains how to resolve the bluescreen issues when updating to 1909 and 1903. 

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

View solution in original post

Replies (23)
7 Thorium
23857

Hello atoss!
In case you have a question about your Dell system or need technical assistance, may I have the Service Tag or Express Service Code or order number, please? I’ll validate your system warranty and get back to you with the available options.

How to find the Service Tag: https://dell.to/2HsL2PN

23819

Have you read this recent post by Dell about a BSOD from SupportAssist in Win 10?

Ron

   Forum Member since 2004
   I'm not a Dell employee

23812

@RoHe

I installed SA on my computer. It didn't seem to be of much help (maybe because mine is an older machine long out of warranty). Since it was so worthless, I uninstalled it right before windows updated to 1903 version. I guess I did the right thing without even knowing it

 

 

 

 

23127

That post says nothing except that a list of approved devices is under study. 

SupportAssist should be thrown out of the window. It’s still safer to download drivers one by one and keep checking regularly.

 

22777

After some months, the problem is still the same even on 1909. 

On an XPS I had the problem, seems it was an intel optane driver and not the support assist for this one. 

But on Latitude 5490, I have lot of bluescreens with support assist installed. Uninstalled it on all computers which had the issue and its working like a charm. 

No problems on optiplex 3060 (Win 10 1909), no problem on my Latitude e7470 (win 10 1909).

2 Bronze
2 Bronze
22671

Same problem on my Latitude 7300 with 1909 installed. Uninstalling SupportAssist worked. Would love to see it fixed.

22667

What about that other dell program, command something or other? Isn't it similar for downloading drivers etc.?

 

 

2 Bronze
2 Bronze
10850

Hey Guys, 

I keep getting BAD_POOL_CALLER issue after installing SupportAssit tool.

My laptop is Latitude 7400, Windows 1909. 

It's already in the tested laptop list:

https://www.dell.com/support/article/us/en/19/sln297954/dell-computers-tested-for-windows-10-novembe...

https://www.dell.com/community/SupportAssist-for-PCs/Update-SA-1903-BSOD-BAD-POOL-CALLER/td-p/731810...

Any update on the issue? It's really strange that such a issue is not solved for 6 months. 

Best Regards, 

Gintautas

29779

@mrgintautas @donm4599x we have found the issue to be caused by an incompatibility with the Intel RST driver. Our recommendation to resolve this issue is to run Support Assist on the system to ensure that the system finds the latest drivers and installs them.

Once done - uninstall Support Assist from the system.

Manually update the latest iRST driver on the system - more info on how to do this can be found here under "Resolution Steps"

If that fails to resolve the issue it is recommended to manually install the iRST driver instead.

Unzip the latest iRST driver for your notebook. Navigate to Windows 10 device manager and locate the Storage Controller. Select the controller that has Intel in it's name. Right click "Update Driver", select driver manually from the drive and navigate to the folder where you extracted the iRST driver too. Choose the Windows 10 folder and select Ok. Once it installs, reboot the system. 

Now install Support Assist and then system should no longer bluescreen.

That article I also provided a link to also explains how to resolve the bluescreen issues when updating to 1909 and 1903. 

Alan

DELL-AlanD
Social Media Support
#IWork4Dell
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

Latest Solutions
Top Contributor