PowerEdge HDD/SCSI/RAID

Last reply by 07-12-2016 Solved
Start a Discussion
3 Silver
61872

PowerEdge 2900 on board sata ports

I have a PowerEdge 2900 server and would like to put in a spare single 2TB SATA drive for some additional (non-critical) storage.  The motherboard has two on board SATA ports, A & B.  When I try to connect the drive to the on board SATA ports, the BIOS does not detect anything, and when I change the type to "Auto", save settings, and reboot the settings do not stay saved in the BIOS.

I'm not sure if the motherboard SATA ports support hard drives, or if there's some other reason things are not working.  I've tried different cables and tried the drive in another computer, and everything works fine in another computer.  I plan to put in some additional SAS drives in the drive enclosure, but am looking for an intermediate solution.

Any help is appreciated.

Thanks
Josh

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
3252

I saw this same issue and fixed it. You have to go to "Embedded Devices" in the bios and enable "Onboard Sata".

View solution in original post

Replies (4)
7 Gold
3252

Just connect the SATA drive to the PERC (hotswap backplane) and configure it as a single disk raid 0. (note: it may not be readable in any other systems that don't have an LSI based raid or SAS controller).

Member since 2003

3 Silver
3251

Don't the SATA drives require an interposer as well?  If the drive won't work on the motherboard SATA ports, I'll just wait until I get additional SAS drives.

Thanks

2 Bronze
2 Bronze
3253

I saw this same issue and fixed it. You have to go to "Embedded Devices" in the bios and enable "Onboard Sata".

2 Bronze
2 Bronze
3250

Excellent!

Latest Solutions
Top Contributor