Highlighted
RVicker
Copper

Replacing disk drive Raid-5, Hotswap

Jump to solution

I have a Poweredge server with a PERC 6i hotswap card that started complaining about a drive about to fail. I replaced the drive with an identical model.

In OMSA under "Drives" it shows the drive as ready, but under "Virtual Drive" it shows degraded and only the original two drives assigned. None of the options show anything to make the drive part of the array as a replacement.

How do I get it to accept the new drive as a replacement and rebuild the array to protected status? While the system is up, after all we did buy hotswap.

0 Kudos
7 Replies
theflash1932
Diamond

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

You need to assign the new disk as a Hot-Spare ... you can choose Assign as HotSpare from the dropdown for that drive on the Physical Disks screen or you can choose Assign Hot-Spare from the dropdown on the RAID 5 on the Virtual Disks screen.

0 Kudos
RVicker
Copper

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

Correction, that server actually has a PERC S300.

When I try actions on the drive I only get Blink, Unblink. From the Virtual Disks it tells me it only shows available drives and that there aren't any.

0 Kudos
theflash1932
Diamond

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

My first guess would then be that the drive is not 'adequate' to be used as a replacement.  You said you "replaced it with an identical model" ... is it a Dell-certified drive (you can get a particular drive model in generic form or as a 'certified' drive for a particular OEM)?  If the drive is smaller than the others in the array - even my just a little (and every brand, model, and even firmware can vary slightly, even for the same marketed size of drive), then it cannot be used.

0 Kudos
RVicker
Copper

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

Same exact model number.

I did just notice that under Virtual Drives it lists a new drive with a name of NONE, No Raid, and as a Windows disk. Windows is also seeing a new, un-initialized disk. I assume now that if I delete this drive it will become available to assign as a Hot-Spare and then from Hot-Spare to the array...

0 Kudos
theflash1932
Diamond

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

Like I said, even the same model number can come in several variations - problems can arise from using non-Dell drives (no Dell PN listed on the drive) mixed with Dell drives.

Yes ... the S300 supports non-RAID/JBOD, so if it has assigned the drive a non-RAID configuration, then deleting it should make it available to use in the array.

RVicker
Copper

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

Deleted.

Assigned Global Hot Spare.

Virtual disk now shows...Rebuilding.

Yeah!!!

0 Kudos

Re: Replacing disk drive Raid-5, Hotswap

Jump to solution

Thanks for the information it worked.  I have one question to ask -

This is the process I followed:

I had one physical disk failed - disk 1.  I inserted my replacement disk but it did not begin the rebuild process because it was labeled as a new virtual disk.  I deleted the replacement virtual disk and then made the replacement physical disk a global hot spare.  The rebuild process started and the RAID5 - 3 disks - is now normal.  

However, under virtual disks, I am now seeing this:

RAID 5 - normal

virtual disk failed

The RAID 5 has the three physical disk labeled:

disk 0 online

disk 1 spare

disk 2 online

Therefore, the global hot spare is label spare and the RAID 5 is normal.  

Question: Can I go ahead and delete the virtual disk failed that is still showing under virtual disks?

Thanks in advance.

0 Kudos