Rack Servers

Last reply by 05-16-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
344

Upgraded idrac8 firmware from 2.70.70.70 to 2.83.83.83 and cant no longer use FQDN to access idrac

v2.83.83.83 was released in April 2022.  We were tasked to upgrade to 2.83.83.83 to correct a vulnerability.  Upgrade worked but can no longer use FQDN to access the idrac.  Can only use the IP address.  When trying to use FQDN we get a BAD REQUEST ACCESS ERROR 400...   

I know from a previous thread this has happened with previous earlier versions of the firmware for idrac.  Any possible fixes.?  Really only tried to perform a idrac RESET which did nothing.

Solutions (2)

Accepted Solutions
Dell Technologies
327

You are seeing this behavior due to host header check in iDRAC. You need to use FQDN mentioned in iDRAC to access iDRAC without this error. Else you need to disable host header check or ad FQDN you are using as an exception. Refer below link for details

https://www.dell.com/support/kbdoc/en-id/000189996/idrac8-https-fqdn-connection-failures-on-2-81-81-... 

 


Thanks,
DELL-Shine K
#IWork4Dell

View solution in original post

284

host name only support letter (a-z), digit (0-9) and hyphen (-). That is why you are getting the message. Can you set DNS name as "x03-xxxxxx-1" and domain name as "lom.xxx-xxxx.com" and check the behavior. If not you can try adding FQDN as an exception as mentioned in below link

https://www.dell.com/support/kbdoc/en-id/000189996/idrac8-https-fqdn-connection-failures-on-2-81-81-... 


Thanks,
DELL-Shine K
#IWork4Dell

View solution in original post

Replies (7)
Dell Technologies
328

You are seeing this behavior due to host header check in iDRAC. You need to use FQDN mentioned in iDRAC to access iDRAC without this error. Else you need to disable host header check or ad FQDN you are using as an exception. Refer below link for details

https://www.dell.com/support/kbdoc/en-id/000189996/idrac8-https-fqdn-connection-failures-on-2-81-81-... 

 


Thanks,
DELL-Shine K
#IWork4Dell

294

So after upgrading the iDRAC to 2.83.83.83 I did notice our 

IDRAC Settings | Network | Common Settings | DNS iDRAC Name changed to this:

idrac-1234abc    (123abc is our service tag)

So I tried to change it to our DNS entry which is named like this:

x03-xxxxxx-1.lom and then of course we have the "Static DNS Domain name" set to xxx-xxx.com

(used "x" to secure our names)    

But when I click apply with the DNS iDRAC name = to x03-xxxxxx-1.lom

I get the following message

bc1410_0-1652703968436.png

 

Im guessing it doesnt like the .lom in the naming convention

 

289

To update FQDN on iDRAC you need to update 2 attribute. Host name to be updates on "DNS iDRAC Name" attribute and domain name to be updated on "Static DNS Domain Name" attribute. So DNS iDRAC name should not have domain name.


Thanks,
DELL-Shine K
#IWork4Dell

288

I get that..  Im guessing its our naming convention - 

our naming convention is this - 

x03-xxxxxx-1.lom.xxx-xxxx.com

It doesnt like the .lom part of the naming convention I guess..

285

host name only support letter (a-z), digit (0-9) and hyphen (-). That is why you are getting the message. Can you set DNS name as "x03-xxxxxx-1" and domain name as "lom.xxx-xxxx.com" and check the behavior. If not you can try adding FQDN as an exception as mentioned in below link

https://www.dell.com/support/kbdoc/en-id/000189996/idrac8-https-fqdn-connection-failures-on-2-81-81-... 


Thanks,
DELL-Shine K
#IWork4Dell

273

Thanks for your Great Help - I followed the link and that corrected the issue..

 

BC

305

Hi, please follow what Shine's said and let us know. Wish you a good one.


DELL-Young E
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

Latest Solutions
Top Contributor