nkut
1 Nickel

racadm lclog view -k <string> doesn't work

I would like to view some LC logs using racadm command. As it's written here there is '-k' flag which "filters the records based on the filter string provided in racadm lclog view command".

So in order to filter particular iDRAC agent message which has particular RACXXXX code I tried to use command as below but got an error:

ssh root@<iDRAC IP> racadm lclog view -k RAC0182
ERROR: The syntax of the command specified is not correct.

I tried to execute a command given as an example in the mentioned above racadm cli guide but it also failed:

ssh root@<iDRAC IP> racadm lclog view -k session
ERROR: The syntax of the command specified is not correct.

Firmware versions:

ssh root@<iDRAC IP> racadm getversion
Bios Version                     = 2.8.0
iDRAC Version                    = 2.60.60.60
Lifecycle Controller Version     = 2.60.60.60
IDSDM Version                    = NA

So I wonder what a proper syntax for '-k' flag usage is?

0 Kudos
2 Replies
DELL-Rey G
1 Nickel

Re: racadm lclog view -k <string> doesn't work

you are correct, the -k parameter doesnt work. It does work on our 14th Gen systems, which use a different version of idrac fw, which isnt compatible with 12g and 13G systems. I believe you have a 13G system based on the bios version you have. if you do a: racadm lclog help view , it doesnt list the -k parameter as a valid option. The 14G systems do list it as a valid parameter. There are 2 possibilities, either the documentation is wrong and it wont be a valid parameter for 12G and 13G systems, or there was a mistake made and it wasnt added in. 
I will check with the idrac team, but I'm not sure when I'll get a reply due to the holidays. 

#Iwork4Dell

0 Kudos
nkut
1 Nickel

Re: racadm lclog view -k <string> doesn't work

Rey, you are right: I meant 13th Gen system. Indeed there is no '-k' flag mentioned in 'racadm lclog help view'. Thanks for your prompt reply and your query to iDRAC team!

0 Kudos