Announcement Banner
UNSOLVED

hYSygvG51312427

updated

15 years ago

0

2734

June 7th, 2011 04:00

unable to restore mail from Exchange 2003/2007 with MAPI_E_NOT_FOUND Error

Hello,

I’ve 2 Exchange servers: an old 2003 and a new 2010. Since the installation of the 2010 Exchange server, users are no more able to restore archived mails whatever they are on the 2003 or 2010 Exchange server.

When trying to open an archived mail, we receive after a 3 minutes “not responding” period the following error messages :

-          With Outlook 2007 : “The message selected is archived & shortcutted, and cannot currently be retreived.”

-          With Outlook 2003 : “Failed to initialize object. Unable to access global address list. Error code was -214767259”. And then “CExchShortcut: Detected invalid input”

-          In the EmailXtender log :

Source : CProcessMailbox

Routine : SetWasteBasket

Description: CProcessMailbox::SetWasteBasket - Caught general exception

HR : MAPI_E_NOT_FOUND

I’ve double check the installation procedure of EmailXtender on the Exchange 2010 server by following the deployment guide for a 2007 Server. I’ve also checked the permissions, and still cannot explain why people on the old Exchange 2003 server are also affected.

Any help will be welcome,

Best regards,

Jeff.