Bohjaaa
1 Copper

Customreboot script failed during Dell Bare metal deployment ST

I have installed DDP 1.2 for Configmgr 2007 SP2 R2
Imported DTK 3.2.1 and created a custom bootimage using the wizard.
Imported Driver packages for server R510
Then used the wizard to create a TaskSequence for a deployment of Windows 2008 R2 Standard.

The wizard is succesfull, and all related packages are on the DP.
I want to do the deployment on unknown computers (not exist in SCCM yet) so I have set the bootimage to enable unknown computer support.
I have created a stand-alone TS DVD media (.iso) and copied the file to a server close to one of the new servers that needs to be deployed.
We use DVD media because we do not use PXE servers. The servers we need to deploy are spread all over the world on all different locations. Creating a PXE server point on all these locations is undoable.

Anyway, I have mounted the DVD iso file to the server via DRAC virtual media (All servers we deploy, we have to manage them remotely so not able to insert DVD or USB flash)
and the server is booting in WinPE correctly.
I configure the local LAN adapter with the correct IP stack info and continue.
Now I receive the unknow computer WinPE pre-hook (HTA), so I fill in the computername, fill in my account info which has full admin acces to the configmgr and continue.
Now I can see tha the computer object was succesfully added to the collection that I have chosen in the boot image creation. So far so good.
Then the set Rebootstep variable starts but immediately fail.
I have checked the smsts.log file and here is outcome of the error:

0 Kudos
4 Replies
Bohjaaa
1 Copper

RE: Customreboot script failed during Dell Bare metal deployment ST


_SMSTSClientGuid variable not found. This means the task sequence is running from stand-alone media
DESCRIPTION: The Custom Reboot action will not work without the ability to write a variable setting. Cannot continue because launch mode is CD and task sequence is in stand-alone mode.
0 Kudos
DELL-Greg R
2 Iron

RE: Customreboot script failed during Dell Bare metal deployment ST

Just to confirm, you solved your issue, right? The RebootStep process does not work with stand-alone media, as it connects to the ConfigMgr provider to set a reboot step on the comptuer object.
0 Kudos
Bohjaaa
1 Copper

RE: Customreboot script failed during Dell Bare metal deployment ST

Hi thanks for the reply.
No I have not solved it yet. This was already my assumption that it cannot be used with stand-alone media.
Then can you give me some advise how to go further?
So if I understand it want to write something in configmgr provider. But in the TS the correct account with permission to the provider are set. It was also able to create the computer object like that.

0 Kudos
Highlighted
DELL-Greg R
2 Iron

RE: Customreboot script failed during Dell Bare metal deployment ST

"Hi thanks for the reply.
No I have not solved it yet. This was already my assumption that it cannot be used with stand-alone media.
Then can you give me some advise how to go further?
So if I understand it want to write something in configmgr provider. But in the TS the correct account with permission to the provider are set. It was also able to create the computer object like that.

"
The Dell Server Deployment Pack (as well as the other Server Deployment Packs) were built for use with USB (ideal) and CD Bootable Media, and PXE.

I don't think any of them will work in a stand-alone media environment.
The problem is that ConfigMgr OSD doesn't support mulitple reboots into WinPE, which is required for creating virtual disks, etc. The Server Deployment Packs get around this by writing a custom variable to the computer object in ConfigMgr.

Are you required to use stand-alone media? If you have network connectivity and connect to the provider, you should be able to use USB or CD Bootable media - have you tried that yet?
0 Kudos