1 Nickel

How to mount ISO file on DRAC5 1.6 (PE2950)

We have a PE2950 installed with DRAC5 with firmware version 1.6


My management station is another PE2950 server having RHEL5.7 32bit OS and installed with Firefox 17.0.9.

I have downloaded the RHEL6.4 ISO file  (3.5GB) on a management station.

I am able to login to DRAC5 using web interface. But what I see on the interface does not jive with DRAC5 1.6 manual.

I want to boot the server from ISO file and install OS.

I do not have physical access to the server.

I need help in configuring virtual media.

I see the following on

Media-->Virtual Media tab:

Attach/Detach status = Attached
Max Session = 1
Active Sessions = 0
Plugin Type = Java

Below the attribute area , I see a button called "Launch VM"


Media --> Virtual Flash

Virtual Flash Enabled = No
Virtual Flash Drive = <BLANK> and browse button is enabled.


Media --> configuration

Attach virtual Media = Attach
Max Session = 1
Active Session = 0
VM Media Port = 3668
VM SSL Port = 3669
Virtual Flash Enabled = NOT checked
Boot Once Option = Disable
Plugin Type = Java


0 Kudos
5 Replies

RE: How to mount ISO file on DRAC5 1.6 (PE2950)


Here is what you will need to do. Hit the Launch Vm button and then mount the ISO. Then select under configuration to do the "Boot Once Option" check mark. Then on reboot the ISO should present to boot.

Let me know how it goes.

Chris Hawk

Dell | Social Outreach Services - Enterprise
Get Support on Twitter @DellCaresPro 
Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
1 Nickel

RE: How to mount ISO file on DRAC5 1.6 (PE2950)

That worked fine. Appreciate your help. Now I have another problem of read only access. I can not do anything. Server has booted from the virtually mounted ISO file, I guess I have read only access even though

Following are the console configuration settings:

Keyboard Port = 5900 (I tried changing to 5909 still no effect)

videoPort = 5901

Console Redirection Enabled = YES

Video Encryption Enabled = NO

Local Server Video Enabled = YES

Maximum Session = 4

Active Session = 1

Plug-in Type = Java

Default Access For Console Sharing = Full Access




Following is the content of vkvm.jnlp file from /tmp directory


0 Kudos
1 Nickel

RE: How to mount ISO file on DRAC5 1.6 (PE2950)

I got it resolved. I went to console window, checked "pass all key strokes to targer" under tools--> session options.

Thanks again.


0 Kudos
1 Nickel

RE: How to mount ISO file on DRAC5 1.6 (PE2950)

I am facing problem again. I am trying to mount media from 64-bit RHEL6.5 machine and I am getting the following error:

java.lang.UnsatisfiedLinkError: /home/user1/.java/deployment/cache/6.0/34/5dbbcda2-4422d3d4-n/ /home/user1/.java/deployment/cache/6.0/34/5dbbcda2-4422d3d4-n/ wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
 at java.lang.ClassLoader$NativeLibrary.load(Native Method)
 at java.lang.ClassLoader.loadLibrary1(Unknown Source)
 at java.lang.ClassLoader.loadLibrary0(Unknown Source)
 at java.lang.ClassLoader.loadLibrary(Unknown Source)
 at java.lang.Runtime.loadLibrary0(Unknown Source)
 at java.lang.System.loadLibrary(Unknown Source)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
 at java.lang.reflect.Method.invoke(Unknown Source)
 at com.sun.javaws.Launcher.executeApplication(Unknown Source)
 at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
 at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
 at Source)
 at Source)

<jnlp codebase="" spec="1.0+">
    <title>DRAC5 Virtual Media Client</title>
    <vendor>Dell Inc.</vendor>
    <icon href="" kind="splash"/>
    <shortcut online="false"/>
  <application-desc main-class="">
    <j2se version="1.6 1.5 1.4+"/>
    <jar href="plugins/vm/VirtualMedia.jar"/>
  <resources os="Windows">
    <nativelib href="plugins/vm/rac5VMWin32.jar"/>
  <resources os="Linux">
    <nativelib href="plugins/vm/rac5VMLinux.jar"/>

0 Kudos
1 Nickel

RE: How to mount ISO file on DRAC5 1.6 (PE2950)

I tried downloading latest jre version both 32 and 64 bit but it did not help. Then I copied jre from a different 32bit rhel server and it worked.

0 Kudos