Systems Management General

Last reply by 04-07-2021 Unsolved
Start a Discussion
3 Silver
6398

dell tools failing to update on Centos 6 & 7

HI

 

When running yum update on Centos 6 and 7 its failing due to missing packages on Dell's repo:

 

---> Package srvadmin-isvc-snmp.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-isvc-snmp.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-itunnelprovider.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-itunnelprovider.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-jre.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-jre.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-nvme.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-nvme.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-omacore.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-omacore.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-omacs.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-omacs.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-omaksmig.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-omaksmig.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-omcommon.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-omcommon.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-omilcore.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-omilcore.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-ominst.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-ominst.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-oslog.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-oslog.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-rac-components.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-rac-components.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-rac4.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-rac4.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-rac4-populator.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-rac4-populator.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-rac5.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-rac5.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-racadm4.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-racadm4.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-racadm5.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-racadm5.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-racdrsc.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-racdrsc.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-racsvc.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-racsvc.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-realssd.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-realssd.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-server-cli.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-server-cli.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-server-snmp.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-server-snmp.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-smcommon.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-smcommon.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-smweb.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-smweb.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-standardAgent.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-standardAgent.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storage.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storage.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storage-cli.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storage-cli.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storage-snmp.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storage-snmp.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storageservices.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storageservices.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storageservices-cli.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storageservices-cli.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storageservices-snmp.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storageservices-snmp.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storelib.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storelib.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-storelib-sysfs.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-storelib-sysfs.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-sysfsutils.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-sysfsutils.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-tomcat.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-tomcat.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-webserver.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-webserver.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package srvadmin-xmlsup.x86_64 0:8.5.0-2372.10488.el7 will be updated
---> Package srvadmin-xmlsup.x86_64 0:9.1.0-2757.12163.el7 will be an update
---> Package syscfg.x86_64 0:5.5.0-2372.10488.el7 will be updated
---> Package syscfg.x86_64 0:6.1.0-2757.12163.el7 will be an update
--> Finished Dependency Resolution
Error: Package: dell_ie_bios-3.1.0-4.43.1.el7.x86_64 (@dell-omsa-indep)
           Requires: libdchbas.so.8()(64bit)
           Removing: srvadmin-hapi-8.5.0-2372.10488.el7.x86_64 (@dell-omsa-indep)
               libdchbas.so.8()(64bit)
           Updated By: srvadmin-hapi-9.1.0-2757.12163.el7.x86_64 (dell-omsa-indep)
              ~libdchbas.so.9()(64bit)
Error: Package: dell_ie_bios-3.1.0-4.43.1.el7.x86_64 (@dell-omsa-indep)
           Requires: libdchapi.so.8()(64bit)
           Removing: srvadmin-hapi-8.5.0-2372.10488.el7.x86_64 (@dell-omsa-indep)
               libdchapi.so.8()(64bit)
           Updated By: srvadmin-hapi-9.1.0-2757.12163.el7.x86_64 (dell-omsa-indep)
              ~libdchapi.so.9()(64bit)
Error: Package: libsmal0-3.1.0-4.43.1.el7.x86_64 (@dell-omsa-indep)
           Requires: libdchipm.so.8()(64bit)
           Removing: srvadmin-hapi-8.5.0-2372.10488.el7.x86_64 (@dell-omsa-indep)
               libdchipm.so.8()(64bit)
           Updated By: srvadmin-hapi-9.1.0-2757.12163.el7.x86_64 (dell-omsa-indep)
              ~libdchipm.so.9()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
root@[~]#

We've got this on 30+ servers and we first found it Mid Dec 2017, I waited 1 month before posting on here in hope dell would fix the issue but I still see this exists so I'm posting it now.

Replies (3)
6362

Hi,

Is this the repo location that you are using? http://linux.dell.com/repo/hardware/dsu/os_dependent/RHEL6_64/srvadmin/

It was updated 3 days ago.


Thanks,

DELL-Josh Cr
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

2282

I am having the same issue updating from RHEL 7.2 to RHEL 7.7...

 

I do not see the lib* files under the Index of /repo/hardware/dsu/os_dependent/RHEL7_64/srvadmin or any of the sub directories

2245

Hello,

 

I can get your feedback to the team that maintains this repo, but in the meantime, I would recommend uninstalling the application and then installing the updated version. OpenManage 9.5 is linked below.

 

https://dell.to/3uzHdhw

#Iwork4Dell
Latest Solutions
Top Contributor