1 Copper

Dell Venue 11 - mobile broadband connect but doesn't load anything

Recently, some of our Dell Venue 11's have been having issues with their mobile broadband. We have a data only O2 sim card in them which says its connected and you can see the data usage increasing on the network side panel. 

However, the speed is incredibly slow, sometimes it doesn't even load webpages, we also have apps that connect to the internet (internal or team view remote control) that thinks there is no internet connection.

We've tried updating to the latest drivers but it's still happening. The first time this happened, I had a spare sim card which I switched with the one in the broken tablet and it fixed it for around a week, but now the same problem has returned. They haven't been updated by Windows updates as we don't want them using all the data up so it's disabled. We have 35 of these devices so we don't want all of them having this issue. 

Anyone got any ideas? I've checked the O2 settings which seem to be correct for a Windows 8.1 tablet. 

0 Kudos