Cooties
1 Copper

Dell Venue 8 7840 running 4.4.4 Wifi Issues

I've had the Venue 8 7840 for a week or two now and it's been running great up until yesterday with a sudden onset of wifi connection issues.

Basically trying to connect to a network with WPA/WPA2 encryption, I enter the password (correctly, checked many times) and it connects to the network for about 3 seconds and then drops out. Nothing to do with signal strength because it happens right next to the router too. Having the same issue at work and at home, my Nexus 4 running 5.0 has no issues connecting to both networks.

Also when hotspotting from my phone, the tablet maintains a connection flawlessly with WPA/WPA2.

Wondering if this is a known issue (seen a lot of generic Android 4.4 and 5.0 wifi issues) and if there's a fix that obviously doesn't involve rooting the device and voiding my warranty.

It does seem like a conflict between the tablet and routers however no other device I have is having any similar issues.

Software version (quite a mouthful) - Venue 8 7840-user 4.4.4 KTU84P eng.BBP803A138500DEL20150123.184606 release-keys

0 Kudos
6 Replies
Cooties
1 Copper

RE: Dell Venue 8 7840 running 4.4.4 Wifi Issues

Also tried rebooting in Safe Mode - same issues still occur so third party apps are probably not the problem

0 Kudos
tchad78
1 Copper

RE: Dell Venue 8 7840 running 4.4.4 Wifi Issues

2.4ghz or 5ghz?

I would also download an app called wifi analyzer.  I was about ready to throw my Chromecast out until I saw that the Auto channel on my router was leaving it assigned to a very clustered channel.  Manually adjusted the channel to a range with next to zero interference and it works like new again.

This may not be the answer for you, but it would be awesome I'm sure to fix this manually (even if it's just a bandage).

0 Kudos
Cooties
1 Copper

RE: Dell Venue 8 7840 running 4.4.4 Wifi Issues

Thanks for the advice - tried it out but unfortunately wasn't the solution. I resorted to a factory reset which seems to have fixed the problem for now but I don't want to have to do that every week... fantastic tablet otherwise though 😛

0 Kudos
mfridman
1 Copper

RE: Dell Venue 8 7840 running 4.4.4 Wifi Issues

Question, how is your wifi reception?  I am having a problem with very weak reception, compared to my Moto X phone in the same location.  I can barely use Skype.

0 Kudos
Cooties
1 Copper

RE: Dell Venue 8 7840 running 4.4.4 Wifi Issues

It's not great but probably wouldn't call mine very weak. I use it a fair bit to stream Netflix and haven't really had it drop out but I do tend to sit fairly close to the router... my main issue lately has been the battery just going from 30% to flat without warning

0 Kudos
izgoi29
1 Copper

RE: Dell Venue 8 7840 running 4.4.4 Wifi Issues

having the same issues.  unable to connect to certain networks at all, other networks would connect for a minute or so, then drop out. 

I found that disabling the McAfee Security App resolved this for me.  I am now able to connect and stay connected.