Highlighted
A-CAST
6 Indium

Migration of Existing VM's to VxRail

Jump to solution

We've recently installed a new VxRail S470 into our environment and my goal is to do live migrations using vMotion and vStorage Motion to move my existing VM's from our vCenter/SAN into the embedded vCenter that comes with VxRail/vSAN.

The one thing that I've tried is to make sure that all Level 3 connectivity between the two environments is enabled and I disconnected/removed a host from my existing environment and tried adding it to my VxRail/vSAN cluster, but due to EVC mode I'm needing to shutdown the service VM's on VxRail to then lower the EVC to be compatible with my existing host servers.

How do I go about doing this since I've read that the service VM's which includes vCenter are part of the VxRail shutdown process, so I'm wondering if there is a way to shutdown these VM's manually? If not, is there another better option?

I read an article on these forums that mentions doing the opposite which is adding the VxRail vCenter to my existing vCenter and then migrate my VM's to VxRail that way.  They are both running version 6.0, but not sure if the EVC will come into play in this scenario.  Both vCenter's are virtual appliances.

Any help would be appreciated as I'm trying to migrate to then retire my existing VMware environment.  The end result is running only my VxRail environment.

Thanks,

Angel

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
A-CAST
6 Indium

Re: Migration of Existing VM's to VxRail

Jump to solution

It turns out that our Network Engineer had to create a route in our Cisco router (gateway) to route traffic to the vMotion network.  I was then able to configure the vMotion adapter and TCP/IP Stack correctly which allowed the vMotion and vStorage Motion to work.

Overall, due to the way our network was configured it wasn't a L3 solution that we ended up doing.  I'm trying to explain it the best I can on what I was told and learned along the way, but in the end...it's all good and it's working!

Thank you for your help.  It was just you and one other person from the VMware Community helping me out with this one...again...thanks.

0 Kudos
11 Replies
8 Krypton

Re: Migration of Existing VM's to VxRail

Jump to solution

Hi Angel, Don't add the node to VxRail cluster. Add it as standalone or in it's cluster in the VxRail DataCenter.

The second option: Moving VxRail to your vCenter is time consuming and not reversable at this time.

0 Kudos
A-CAST
6 Indium

Re: Migration of Existing VM's to VxRail

Jump to solution

Ok, I'll try that and let you know how it goes....thanks.

0 Kudos
A-CAST
6 Indium

Re: Migration of Existing VM's to VxRail

Jump to solution

Well, I tried it but got stuck in the license part.  It claims that if I move forward I will be non-compliant because the license on my host server is assigned to a separate vCenter server and if I try using an Evaluation License it says there is none available.

My VxRail system is currently configured with Eval licenses until I'm done with the migration, but I already have legit licenses for the nodes within the VxRail.  This node however is an existing one from my original vCenter which I want to keep licensed until after I've completed the migration.

Is the only option to move forward and see if the VM migration goes successfully? Once I'm done with the VM's on this host I will be applying the new license from VxRail, so the compliance issue is temporary...is that ok?

0 Kudos
8 Krypton

Re: Migration of Existing VM's to VxRail

Jump to solution

I think this should be OK since it is temporary.

About the EVC: there is a procedure in SolVe how to change the EVC mode on VxRail:

0 Kudos
A-CAST
6 Indium

Re: Migration of Existing VM's to VxRail

Jump to solution

Yes, I was made aware of this by the Dell EMC engineer that did the install, so I got the SolVe Desktop app with access to documentation, but your other option worked.

I was able to add the host as a standalone one to the datacenter instead of the cluster.  I also got past the license issue, since it's only temporary and doesn't affect me since I will be retiring this other VMware environment after migration.

The only problem I have now is that the vMotion test I did failed due to a connectivity/communication error.  It says that the standalone host could not communicate with the VxRail host via it's vMotion port.

I used Putty to do SSH sessions and connected to both hosts and confirmed this:

My VxRail host was able to ping both the IP of the standalone host and vMotion IP, but my standalone host can only ping the IP of the VxRail host I'm trying to migrate to but not the vMotion IP.  Any ideas on what I would need to do?

I've uploaded the image of the error that I'm getting for reference.

vMotion Error.png

Thanks,

Angel

0 Kudos
8 Krypton

Re: Migration of Existing VM's to VxRail

Jump to solution

I suspect your vMotion ports on the old ESXi and VxRail are in different subnets/VLANs. If this is the case you have to to vMotion over L3. Take a look at this blog:

Configuring the vMotion TCP/IP Stack for Layer 3 vMotion Across ESXi Hosts - Wahl Network

0 Kudos
A-CAST
6 Indium

Re: Migration of Existing VM's to VxRail

Jump to solution

You are correct, source host and destination host are on different subnets, so I'm currently using a VMware document that talks about adding a new VMkernel port for vMotion to communicate with the destination host but that's not working for me at the moment.

I'll take a look at this blog and see if it helps, I'll post back my test results...thanks for the info.

0 Kudos
A-CAST
6 Indium

Re: Migration of Existing VM's to VxRail

Jump to solution

This is similar to the document I read located here: https://docs.vmware.com/en/VMware-vSphere/6.0/com.vmware.vsphere.vcenterhost.doc/GUID-5211FD4B-256B-...

Regardless, using this info along with the blog still doesn't work for me.  Here is how my environment is configured:

Source Host:

VirtualSwitchesOnSourceHost.png

VMkernelAdaptersOnSourceHost.png

I create a new VMkernel adapter and assign it an IP from the destination host's subnet, but it still tries to use the default gateway and DNS from the source.  Any ideas?

0 Kudos
8 Krypton

Re: Migration of Existing VM's to VxRail

Jump to solution

Could you post the TCP/IP stacks screen please? From both ESXi.

gateway-tcp-stack-12

Also the routing table of the ESXi hosts (both)

# esxcli network ip route ipv4 list

0 Kudos