Windows 10

Last reply by 04-11-2022 Unsolved
Start a Discussion
2 Bronze

XPS 13 9365 touchscreen stopped working after windows reset

So my laptop crashed and the only option i had was to reset the windows. It basicaly wasn`t booting the system after the restart. After i did the reset my touchscreen stopped working. I don`t find the HID device in the device manager and i can`t find anything on the internet. I tried reseting the laptop again but it didn`t help. Furthermore there is a device 'I2C HIDdevice' which is not working as well. My waranty just expired and i really don`t have many options so if someone has a solution i would be really grateful. 

Replies (4)
5 Rhenium

Any way you could share what you were seeing during your earlier problems?  Were you seeing any problems with the touchscreen then?

Have you yet updated the system to the new Win 10 build 1809?

Since some have made registry changes for the system, have you ever do so?

On my system, the Touchscreen has no drivers loaded and the events tab show it was configured with input.inf.

It hangs on the Intel Serial IO I2C Host Controller - 9D60 which you can see if you look at devices by connection in the Device manager.  It is on the same tree as Dell Pen Service, along with the keyboard and mouse.

The Pen service uses mshidkmdf.sys and HIDRouterISD.sys  The parent controller uses iaLPSS2i_I2C.sys.

Since you have already reset your system, you have a few options.  Upgrade to the latest version of Windows, do an in-Place repair by reinstalling your current Windows build over you current install, using a Win 10 recovery drive to put the system back to factory conditions or doing a completely clean install.

But for now, all I can do is recommend you, probably again, make sure all your drivers are installed starting with the chipset and Bios.  Run the system file checker using the Admin command prompt and SFC /scannow.  There is probably some page showing how to troubleshoot problems with the touchscreen, if you have not already been there.

XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720
System fully Win 11 compliant

I already tried every possible solution but nothing seem to work. Everything is up to date i even installed the latest BIOS update but i did not resolve the problem. Furthermore in the properties of My Computer it says that " No pen or Touch Input is available on this Display". I don`t know if it is related but every time a plug a device in the headphone jack i have to restart the PC because it does not recognize it.

Get rid of that **bleep** it's not worth your time. 

To fix your audio problem, Click Here to download the Realtek HD Audio driver.

Run the program and make sure to select "Restart Now" when prompted, it makes sure it runs as intended. it does this twice

Top Contributor
Latest Solutions