Windows 10

2 Bronze

XPS 8700 needed UEFI secure boot disabled to complete Windows 10 anniversary update can't enable UEFI secure boot now

I have a Dell XPS 8700 that failed Windows 10 anniversary update until UEFI secure boot was
turned off.
It apparently then completed but I cannot re-enable secure boot without the same boot problem advising

your pc/device needs to be repaired / during Windows 10 anniversary update
An unexpected error has occurred
Error Code 0xc0000185
you'll need to use recovery tools.  

Is there a solution to enable UEFI secure boot ?

 I am using a Dell XPS 8700 pc with an SSD drive. The Windows 10 update was installing
then after one of the reboots the error above
  The pc was running prior to the update and had UEFI OS , secure boot enabled,  no prior problems.
I attempted to do any of the safe mode boots but none would proceed.

Disabling the UEFI safe/secure boot mode apparently let the install continue and the d
as it did before with I believe completion of the installation of Windows 10 anniversary update.
PC now shows Windows 10 home Ver 1607 ..

The problem returns if I enable UEFI secure boot and the PC stops. I would like to determine a way
to locate the problem or issue. related to the secure boot.  Using the media creation tool may just
repeat the problem once secure boot is re-enabled.

 Dell lists that they have tested XPS 8700 with this update and have not indicated problems no mention of secure boot issue.

Replies (5)
Community Manager
Community Manager


If your computer was running WIndows 10 without any issues prior to downloading the Anniversary update, then you would not have had to change any settings in the bios to install the update.The UEFI and Secure Boot settings are to enable booting with a USB or DVD to install Windows.

Disable Legacy Boot Mode and Enable UEFI

Start the computer and TAP the F2 key to enter the bios. Once in the bios Press F9 to Restore the bios to the Default Settings. F10 to save changes and exit. You could have a hardware problem. To run a hardare diagnostics on the computer you would start the computer and TAP the F5 key. Insert a cd/dvd in the optical drive for running the diags.



2 Bronze

To Jesse L ,

My computer Dell 8700 XPS was running Windows 10 without issue prior to Microsoft downloading

the anniversary update. I made no changes to any settings until after the error occurred and it occurred during the update on one of the many reboots it requires. It stopped , hung quit with a blue screen. It would not continue. Each time I tried to reboot the same error I listed.  I changed the bios setting after the error and it started and appeared to continue the update as it got to where it said Hi and on and on.

If I look at the Windows version now it is 1607 as I said. If  I change the setting back to UEFI secure boot as it was before and I would assume the default since I would never change it before the update the same error occurs.

Community Manager
Community Manager


This code indicates that the boot loader files are damaged or missing,It can also mean that your hard drive is failing. If you run the diags on the system and find that the drive has not failed, then you will need to rebuild the boot loader files from Win10 installation media. You can create the media from the link below if you do not have the media. 

Windows 10  Download

You can then boot from the media you created, but do not install Windows, instead, do a Startup Repair -- and do that three times.Once you have completed the repair your computer should be fine.

Click the link below for for information repairing the computer. The information is for Windows 8, but is the same for Windows 10.

How To Fix Error Code 0xc0000185



2 Bronze

To Jesse L,

 Yes I have found the strange problem, boot loader files missing or damaged actually just non existent..

Prior to the Windows 10 update for months there has been a USB key in the monitor USB port with data files from various things, no system files or boot files or hidden files.

I removed the USB key and re- enabled UEFI secure boot and that is all it took .

Prior to the Windows Anniversary update the USB key was there and no problem but

after it for some reason thought it should or was checking the key I guess to boot from it.

It was running and booting ok with the key in before the update.

Community Manager
Community Manager


Glad you got it resolved.



Top Contributor
Latest Solutions