DFin_S
Copper

A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

Just fixed this issue with a customers Vostro 3750.

The latest Support drivers cause DPC latency of half a second at a time once every 60 seconds and a lot more smaller pauses in between. The problem can be seen as mouse cursor is stuck for a moment and if there's audio, you'll hear a buzzing sound.

See more user experiences at: http://www.sevenforums.com/sound-audio/361186-audio-stutters-buzzing-caused-dpc-latency.html

A correct solution at the moment seems to be disabling the system device Dell Diag Control Device (i.e. DDDriver64Dcsa.sys) until new version is published.

Hope this helps someone to avoid all the troubleshooting we had to do...

greetings,

 THe

46 Replies
Spinneyhill
Copper

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

My Studio 1909 (Win 7 Home Premium) installed Dell Data Vault and Dell SupportAssistAgent yesterday. It had barely finished and I got the blue screen of death. Our other Studio 1909 installed it on Friday and immediately had the same thing. Both computers crashed regularly with blue screens yesterday. So I am trying to resolve a crashing problem on two computers.

I have turned off the Data Vault service and Data Vault Wizard services. If that works, I'll find out how to prevent them starting on startup. If necessary I'll uninstall Data Vault and Support Assist.

Come on Dell, what are you doing foisting poor software on your users?

0 Kudos
gdbug
Bronze

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

I can't help you. I was hoping that you had received help that would help me.

I open task manager every time I start the computer. I do this so that I can see what all is running, and allow memory and disk hogs to do their thing before I do anything with my computer.

Just now, after starting the computer, I noticed Dell Data Vault (delldatavault.exe) running. It is located at c:\program files\dell\dell data vault. The properties says that it was created on January 30,  2015.

I've never seen this exe before, and I was wondering what it is, where it came from, why it is on my machine, why it is on my machine now when I've had it since August 2013, and why has it never been shown to be running before, yet it is running now.

I hope someone clears this up here. Otherwise I guess I will have to consider it malware and get rid of it.

0 Kudos
mman454
Bronze

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

Same issue here on my XPS l502x.

I have found that disabling the Dell Data Vault and Dell Data Vault Wizard services have also had the same resolution. It's not a proper fix, but who knows how long it's going to take Dell to release a bug fix update.

0 Kudos
DFin_S
Copper

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

Just found out that disabling this service is not a sufficient fix. The service will get loaded despite the device is disabled. Uninstalling all Dell Support components seems to be a proper fix until Dell releases a working version.

-THe

Highlighted
mman454
Bronze

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

Earlier you said that you just disabled the drivers. Did you disable the services as well through services.msc?

0 Kudos
gdbug
Bronze

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

WHY it is there all of a sudden, is what I want to know. I bought this computer in August or September 2013, and it hasn't been here before. You'd think that Dell would get on this thread and clear this all up. Is anyone even sure it is actually a Dell program? What is its sudden need to activate after a year and a half? This is too fishy for my blood.

0 Kudos
Moderator
Moderator

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

A fix has now been developed and successfully tested internally for this issue, however we feel it's important at this time to assist customers with this hotfix to ensure it addresses the problems they are seeing in their particular configurations before posting the fix for wide distribution.

We have already contacted a number of customers who reported the issue on other forums and thus far, results have been positive. If you would like us to work with you to implement this hotfix, please place a reply into this forum and we’ll contact you as quickly as possible or send mail to supportassist@dell.com

DELL-Joe B
Social Media and Community Professional
#iwork4Dell

0 Kudos
Bandit1949
Copper

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

What is Dell Data Vault service, Where did it come from, Why did it suddenly appear on 01/30/2015 on a 15 month old XPS8700, Why do I now get this message every time my computer boots:  "Dell Data Vault service terminated unexpectedly", and Do I have to uninstall Dell Support Services to correct this?

0 Kudos
HulkingThor
Copper

RE: A major bug in the latest SupportAssist / Dell Diag Control Device

Jump to solution

When will this fix be available for all? Or can  I go about getting the hotfix at least?

0 Kudos