JeffO-2015
2 Bronze

Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

We recently purchased Xenith units. When logging onto a virtual desktop through our Citrix web broker (Citrix XenDesktop4), the unit logs on successfully, shows a white screen for 1.5 seconds (including the remote mouse icon), then immediately logs out of the session. It doesn't matter if it's W7 or XP virtual desktop.

No event log errors on the Xenith or in Citrix show why it is doing this. Logging on to our VDI environment works fine on fat clients or through Windows embedded thin clients. Only the Xenith shows this log on/white screen/log off problem.

We are hoping to adopt Wyse Xenith zero clients as our defacto thin clients, but we are stumped by this error. Does anyone have any suggestions?

Jeff O.

0 Kudos
7 Replies
Rmontalvo1
3 Zinc

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Jeff,
Are you using an INI file? What if any configuration parameters have you defined on the client?

 

 

 


Roger Montalvo 
Visit our Dell Wyse Thin Client Knowledge Base and Manuals web site at www.wyse.com/KB
Visit our Dell Wyse PocketCloud Knowledge Base and Manuals web site at http://pocketcloudsupport.wyse.com/forums
[SIGPIC][/SIGPIC]

Tags (2)
0 Kudos
JeffO-2015
2 Bronze

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Hello Roger, thanks for the reply. We are currently not using an INI file for configuring the unit. We simply followed the guide for setting the unit up out of the box. If we are successful in getting XD4 to work, then we will be implementing changes to our DHCP configuration and setting up an FTP service. 

For clarification, all of our domain users have access to the pooled or assigned desktops (XD4) available through the Citrix DDC. They logon every day to the pool or their assigned VM successfully through IE8 or PXE boot. It's only when trying to access a desktop through the Wyse Xenith appliance that this strange logon/logoff issue applies. It does not happen when we change the broker URL on the Xenith to our XenApp6 farm; users are successful in accessing published apps. (Our goal is not to use the Xentih for access to published apps, but rather desktops.)

Thin clients work fine though for XenApp6 published apps. Only the http://x.x.x.x/Citrix/DesktopWeb entered as the XenDesktop Broker Server URL does this quick logon then immediately logoff thing.

Jeff

Tags (2)
0 Kudos
Rmontalvo1
3 Zinc

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Try using the complete path including the config.xml . i.e. http://x.x.x.x/Citrix/DesktopWeb/config.xml

 

 

 


Roger Montalvo 
Visit our Dell Wyse Thin Client Knowledge Base and Manuals web site at www.wyse.com/KB
Visit our Dell Wyse PocketCloud Knowledge Base and Manuals web site at http://pocketcloudsupport.wyse.com/forums
[SIGPIC][/SIGPIC]

Tags (2)
0 Kudos
Highlighted
hangulo1
3 Argentium

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Jeff- Actually with Xenith you dont need to enter the "full" path, in my environments I just enter the IP address the the URL field ("10.100.1.50"). Give that a try. Also, Can you check what build of XD4 you are using?

Tags (2)
0 Kudos
JeffO-2015
2 Bronze

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Quote Originally Posted by RMontalvo View Post
Try using the complete including the config.xml .i.e. http://x.x.x.x/Citrix/DesktopWeb/config.xml

The same problem occurs.

Tags (2)
0 Kudos
JeffO-2015
2 Bronze

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

Quote Originally Posted by hangulo View Post
Jeff- Actually with Xenith you dont need to enter the "full" path, in my environments I just enter the IP address the the URL field ("10.100.1.50"). Give that a try. Also, Can you check what build of XD4 you are using?

If I enter just the IP of the DDC on the Xenith, it will show me the published apps available through XenApp6, because the DDC has that server listed in its Web Sites list. Accessing those published apps works fine. 

If I logon the Web Interface Manager for the DDC, I see two web sites listed: x.x.x.x/Citrix/DesktopWeb and x.x.x.x/Citrix/Xenapp. (It was setup this way by a Citrix Engineer in the spring during its initial setup.) 

Just to reitierate, XD4 works fine. Our users use it every day through IE8, FireFox, etc. But on the Xenith, it fails everytime.

XD4 is currently fully patched (PVS 5.6, XD4 client side 4.0.5013)

Tags (2)
0 Kudos
JeffO-2015
2 Bronze

RE: Resolved: Xenith logs on then logs off immediately (use clearlicense=yes)

We were never able to resolve this problem in XD4. However, standing up a XD5 DDC and migrating the existing VMs to it, the Xenith device works great.

Tags (2)
0 Kudos