Last reply by 11-16-2019 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell XPS L702X doesnt start


I have a issue with my Dell XPS L702X. It doesn't start. It shows that my AC is connected a charging (white led in the back and battery sign in the front, also blue led on the cord showing it has power) but when the power button is pressed, nothing happens. 

I've found some solved cases here on this message board but those include beeping sounds, fans starting or stuck in the boot process but in my case it doesn't do anything.

One other solution i found was on youtube, where i should disconnect the motherboard battery and discharge the system, but i couldn't detached the casing on the bottom. 

I've tried to start it without battery only on AC, but nothing happens and no leds are blinking. I've tried only on battery and nothing happens. There's a power indicator on the battery, when pressed all leds are lit. 

Before i really try to unscrew every screw and detach my ram modules i want to be sure the problem lies there and not something "simple". So i hope this information will help. 

Fingers crossed, hope that somebody can point my in the good direction  


Reply (1)
2 Bronze
2 Bronze

After leaving it uncharged for the night, the battery is showing just one dot but when i push the power button still nothing happens. Normally it would show me a orange status led that the battery is low but nothing. Also when the battery is out and i'm trying to boot the system, nothing happens, no status leds or anything. I really don't know in which direction this will go. Might be the motherboard or the battery or something else....
Latest Solutions
Top Contributor