XPS

Last reply by 01-18-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
445774

Intel Optane Memory Pinning, error

getting this error message, any help welcome

Intel Optane(tm) Memory Pinning : can not load the file DLL ´iaStorAfsServiceApi.dll´ : Can not find the specified module. ( Exception HRESULT : 0x8007007E).

Replies (59)
Not applicable
9797

how to remove this error .

18052

The error started popping up right after the latest Windows 10 Insiders Preview update. The simple fix of going to the App in Settings and selecting "Modify" worked for me also. Thank you!

293699

this works.

after the repair just restart.

293539

Thank you for the solution. It worked. 

300897

Welcome to the Dell Community.

* From your Service Tag page, click DRIVERS & DOWNLOADS
* Select the Serial ATA drop down category
* Look for the latest Intel Rapid Storage Technology Driver (version 15.5.2.1054 or newer)
* Download/install. When done, restart the PC and retest

* Go to the “Control Panel”
* Click on “Default Programs”
* In the lower left hand corner click on “Programs and Features”
* First you could try to "Repair/Modify" any "Intel Optane Software" that may be installed (Memory and Storage Management, Pinning Explorer Extensions)
* Reboot and test
* If that does not work then “Uninstall” any "Intel Optane Software" that may be installed
* Reboot and test

Best regards,

U2

 

Quick Background on Intel Optane Memory

293348

Thanks..This solved problem with this error

293336

Your very welcome @ganeshkp 

Regards,

U2

19700

Worked after applying the repair, thanks.

2 Jasper
2 Jasper
6712

This problem is back with the Intel RST update 17.07.0.1006 and the listed solutions are no longer possible with this update.   I am mulling an uninstall of it.

6701

I resolved this once in November 2019 by installing SetupRST.exe 17.7.0.2 on my XPS 15 9570.  However, I did the Windows 10 Pro upgrade to 1909 and found this issue had returned.

The release notes for iRST 17.7.0.2 include a line that looks to indicate that the pinning error was resolved.      I uninstalled RST and reinstalled it - issue resolved.

Latest Solutions
Top Contributor