XPS

Start a Discussion
2 Bronze
2 Bronze

XPS 13 9350 not charging with USB-C or adapter

As many others, I'm having the issue of "plugged in, not charging". This happens when I'm using USB-C (from a Dell dock) and also when I'm using the Dell adapter.

I've:

  • switched the battery setting to Standard instead of Adaptive
  • fiddled with the adapter to see if it was a bad connection
  • opened up the case, unplugged the battery (and adapter and usb-c), pressed the power button for 10 seconds (to remove any left over power)
  • removed the screw from the power jack and tried charging (because some solutions talk about a bad earth there)
  • run the system check after pressing F12 at boot (no errors reported)

I've also checked the BIOS, and installed Dell Command | Power Management. Both say my battery is in excellent health. Both recognize what's plugged in. The USB-C connection and the Adapter are recognized as 45W.

I'm stuck at 26% battery, although that seems random (it was somewhere in the 30s a few days ago, and has also been stuck at 24%).

I realize it's most likely something is broken. From what I've read, it could be either the power jack of the motherboard.

My question is this: can I safely assume it's not the power jack, because charging via USB-C doesn't work either? Is that a correct train of thought?

Labels (2)
Solution (1)

Accepted Solutions

A fortunate update! I had noticed that my mouse trackpad was raised a bit on one side. Reading online, I concluded my battery was swollen, which is potentially dangerous. I ordered a new battery, replaced it, and now my problem is fixed.

View solution in original post

Community Accepted Solution
Replies (10)
6 Indium

When you try a reset follow this procedure. Disconnect the battery. Then unplug the adapter. Now press and hold the power button for 30 seconds. Now reconnect everything and try again. If that does not work then run system diagnostics. Start the system and at the Dell splash screen start tapping F12. Run full diagnostics. Also check the battery and adapter to be sure they are detected in the BIOS. At the Dell splash screen start tapping F2. If battery health still is excellent and the adapter is detected as a Dell adapter then only 2 possibilities remain. The pin on the DC power jack is bent or broken and the jack needs to be replaced, or the problem lies on the motherboard. In which case the motherboard will need replacement.

The following post might help as well.

http://www.tomsguide.com/answers/id-3406008/dell-xps-9350-plugged-charging.html

 




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-450M Pro-VDH Max budget build with an Athlon 3000G
Real work on a Latitude E5430

Thanks for your reply @JOcean, but unfortunately, it makes me feel like you didn't read my question. I've tried what you said, as I listed in my question.

And if the pin is bent or broken, then I'm assuming charging via USB-C would still work? That's exactly what I'm asking: am I right in assuming it's the motherboard?

Thank you for your message. Did this issue start after any BIOS update or BIOS changes?

 

Is the battery level the same in Dell Command, battery icon in the notification bar & in BIOS?

 

If you press the battery charge stats button does it indicate that the battery charge is low?

 

Have you tried to drain the battery completely & check if the system charges after that?

 

For my reference, please click on the message tab next to your avatar– click “New Message” & search for my Dell username (Dell-Sreejith R) & send a private message with the service tag, registered name & email address.

 

What is a Dell Service Tag and how do I locate it?

 

 


Dell-SreejithR
Social Media Support
#IWork4Dell

This did not start after a BIOS update or change. Though I have tried updating my BIOS in hopes of solving the issue. It did not.

All tools (BIOS, Windows, Dell Command) indicate the same battery percentage. The LEDs on the side of the laptop indicate about the same (2 of them light up).

I will try draining the battery completely and report back.

Unfortunately, I only reached 30%.

This is what I did:

  • unplugged both USB-C and adapter
  • waited for laptop to shut down automatically at about 5%
  • rebooted and entered BIOS
  • waited for battery to drop to 0% and have laptop stop
  • pressed the powerbutton 2 times to make laptop try to boot again (didn't work of course)
  • plugged in adapter, waited for a while and rebooted

Dell Command | Power Management now says "30% available, plugged in, not charging". Though I've seen it sometimes switches to charging for a few seconds and then back to not charging. But I'm thinking that might be because it's using power when not charging, then notices it can charge, charges to 30% and then stops charging again.

So we're probably looking at a motherboard replacement here?

This does seem to be an issue either with the motherboard or the DC-in cable.

 

Are you using the original AC adapter shipped with the computer?

 

Please share the service tag along with the registered name & email address on a private message. I will assist you as per the warranty & get the parts replaced. 

 

 


Dell-SreejithR
Social Media Support
#IWork4Dell

I'm using the original AC adapter.

As I'm also having the issue with USB-C, I assume it's the motherboard? Or does USB-C somehow use the DC-in cable? From what I could see, I think the USB-C is directly connected to the motherboard.

I'll send you the service tag and other requested details.

For anyone coming here in search of a solution: I did not fix it.

I summed up above what I tried. Nothing worked. I finally ordered a new DC jack and replaced it. This did not fix it unfortunately. Another possible solution could be to replace the motherboard. But new motherboards for the XPS-13 come at around €700, which is not a cost I'm willing to make if I'm not sure it will be fixed.

I have found that putting the adapter in for a long time will "trick" the system into thinking it's at 100%, but it isn't really. The battery will still only get about 1 hour of usage. So even though it says 100%, it's still actually at around 30%. This can also be seen, because it drops rapidly.

This is very unfortunate, because I really like my XPS 13 otherwise. Alas, no fix here.

A fortunate update! I had noticed that my mouse trackpad was raised a bit on one side. Reading online, I concluded my battery was swollen, which is potentially dangerous. I ordered a new battery, replaced it, and now my problem is fixed.

Community Accepted Solution
Top Contributor
Latest Solutions