Last reply by 03-26-2023 Solved
Highly Active TopicHighly Active Topic
Start a Discussion
2 Bronze
2 Bronze

XPS 15 7590, Memory Integrity on causes an inaccessible boot device

XPS 15 7590

Hey all,

Just wanted to report a minor bug with a fresh install on Windows 11 22H2 on XPS 15 7590.

When trying to turn on Memory Integrity under Device Security / Core Isolation, upon next reboot i get a blue screen with Inaccessible Boot Device.

Yes, I'm using the latest Intel Chipset Drivers and XPS 15 7590 firmware.

Yes my Windows 11 is up to date.

<Your purchased 1 year warranty expired on August 2, 2020. DELL-Admin>

Replies (183)

Have any of you looked at the report from msinfo32.exe to see if the Virtual settings look something like mine?  This is a Desktop, but available settings may be close.


XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant
Community Manager

This issue is being researched by Dell. When we know more, we will post.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

2 Bronze
2 Bronze

Just wanted to chime in that I'm experiencing the same exact issue.  I would try to enable WSL2 and when rebooting, I would get the same inaccessible boot drive error and would have to restore from a recovery point.  I've also mentioned this on Microsoft's forums with hope that it gains traction to get resolved.


Same issue here while trying to upgrade to Win11 22H2.
Having WSL enabled and in use erroring the upgrade after reboot with a disk-error not found and reverting the upgrade back.

2 Bronze
2 Bronze

This bug is not minor. Those of us that purchased an XPS 15 with the intent of moving to Windows 11 cannot. 


Prior to disabling Virtualization Direct I/O in BIOS, just suspend BitLocker using the 'Manage BitLocker' panel in Windows, it will temporarily disable bitlocker checks on boot. Bitlocker  gets re-enabled after restart.

2 Bronze
2 Bronze

After disabling Virtualization Direct I/O the upgrade from Windows 10 finally worked.

Lucky I finally found this thread and didn't have to reset the laptop (XPS 7590).

2 Bronze
2 Bronze

Is this Solved? any reply from Dell or Microsoft? 


See posting on =

Core Isolation Memory Integrity, incompatibility

Seems to be an Intel/AMD issue for many more machines. We have to wait or use the workaround listed in that topic if you are able to untick Hyper-V and relevant parameters.

2 Bronze
2 Bronze

Although I am not sure, I believe this same issue is preventing me from installing WSL on windows 22h2. Each time i enable Virtual Machine Platform my machine will not boot and goes into repair mode.

Latest Solutions
Top Contributor