Last reply by 03-26-2023 Solved
Highly Active TopicHighly Active Topic
Start a Discussion
2 Bronze
2 Bronze

XPS 15 7590, Memory Integrity on causes an inaccessible boot device

XPS 15 7590

Hey all,

Just wanted to report a minor bug with a fresh install on Windows 11 22H2 on XPS 15 7590.

When trying to turn on Memory Integrity under Device Security / Core Isolation, upon next reboot i get a blue screen with Inaccessible Boot Device.

Yes, I'm using the latest Intel Chipset Drivers and XPS 15 7590 firmware.

Yes my Windows 11 is up to date.

<Your purchased 1 year warranty expired on August 2, 2020. DELL-Admin>

Replies (183)
2 Bronze
2 Bronze

After I tried twice and failed before found this discussion.


Now I am able to upgrade from Windows 11 21H2 -> 22H2 with Windows 11 Instaltion Assistance succesfully by just disabling Virtualization Direct I/O in BIOS.

2 Bronze
2 Bronze

Unfortunately, if I disable the Virtualization Direct I/O in BIOS, it enters a recover mode which asks me to input the bitlocker key. 

I have to enable it. At least I can use windows 11. 


I also too. But you should have BitLocker Key already, right? You can grab your bitlocker key before you change the setting from microsoft account.


Does that mean I need to recover the system so I would lose my data?


Nope. Bitlocker is asking because you have change a setting and after key in, it is just allow you to change. All your data will be intact.

5 Rhenium

There is a new update available, KB5017389.  It mentions repairing a problem.  I do not know if this situation is involved in what you are seeing.

  • Addresses an issue that affects some processors. This issue occurs when you turn on Hyper-V and kernel Direct Memory Access (DMA) protections.

XPS 9365, Inspiron 7567 Gaming, Inspiron 7779, XPS One 2720, AW3423DW
System fully Win 11 compliant

I have tested it. It doesn't solve the issue


I tried KB5017389 on my XPS 15 7590, Windows 11 22H2.
It did not help. I still get Blue Screen on startup and need to use a Restore Point.

I am thinking about disabling Virtual Direct I/O... but I think I need it for Hyper-V to run windows servers in docker.


Yes, Disabling Virtual Direct I/O works for me. I wanted to run Docker with Hyper-V on Windows 11 22H2, on XPS 15 7590, and now I can do it.

Bios settings: SATA=AHCI, Virtualization=ON, Virtual Direct I/O=OFF.
I also installed KB5017389.

After turning Virtual Direct I/O OFF I had to give my recovery key to be able to start Windows, but after that everything was ok and nothing changed.

For me it works with AHCI, I do not know about RAID.

2 Bronze
2 Bronze

Ok I tried to disable Virtual Direct I/O. After entering the bitlocker key I can enable Core Isolation in win11. I use RAID in bios, not AHCI.

Latest Solutions
Top Contributor