Highlighted
Fab_Bear
1 Copper

XPS 9360 Battery ONLY charge through USB-C.

Hello to everyone,

The Dell power adapter is not being recognized. The device is plugged in but not charging. I have tried another Dell charger which i know works fine to no effect here.

When i plug a regular charger the frontal light stay on for about 5 seconds - as it should normaly do when charging - then turn off.

See attached 2 screen shots.

Battery is working fine. I can charge it fully with my spare Dell USB-C charger (photo taken before i plug it with it).

There is a message with both Dell charger saying that they are not recognized?! Both legit Dell charger which WORK perfectly on my other XPS 9360 laptop.

Battery.jpgHealthy BatteryBattery2.jpgNot recognized legit Dell charger?!

I have tried:

Plugged in a couple of working AC adapters directly in different rooms to no effect.

I have uninstalled the Microsoft ACPI-compliant control method battery from device manager and re-install to no effect.

The charger port was even replaced (brand new) to no effect.

I did not try downgrading the BIOS yet...not certain it will be a fix either?

Plugged a Dell USB-C charger and it worked but it should not be a long term solution.

Any idea or solution please?

Thanks.

0 Kudos
1 Reply
jphughan
5 Rhenium

Re: XPS 9360 Battery ONLY charge through USB-C.

@Fab_Bear  if AC adapters that you have confirmed are good via testing with other systems are showing up as unrecognized and the battery charges properly over USB-C, then the fix will be either replacing the AC adapter jack (if that's a separate part on that system) or the entire motherboard (if it's not).  If the system is still under warranty, I would contact Dell to arrange a repair.  If not and the AC adapter jack is a separate part, that part should be very inexpensive and easy to find and install.  If you need a whole new motherboard, you might decide it makes more sense to simply rely only on USB-C power sources, although that admittedly might be difficult if you have other USB-C devices that don't supply power given that the system only has one USB-C port.

0 Kudos