Highlighted
2 Bronze

XtremIO CLI

Jump to solution

I've been tasked to provision 3 new virtual host on XtremIO. I have done provisioning with symmetrix and know the procedure to add host. Create and add initiators to correct Initiator group then Zone. I've googled and found a few different variations from other sites. I would like to get some input from Dell EMC.

I downloaded and skimmed through docu62760_XtremIO-4.0.2-and-4.0.4-Storage-Array-User-Guide. Did not get the definitive answer I was looking for.

I found the below commands but am a little fuzzy on where the command associates with the array. With symmetrix you would use the -sid xxxx to identify which array your running commands against. With multiple different XtremIO arrays that these new host need to be provisioned to I am unsure of commands to use.

Create the IG and assign to the parent folder “VDICluster”:

add-initiator-group ig-name=”VB001_ESXI01″ parent-folder-id=”/VDICluster”

Add the ESXi HBA’s to the relevant IG:

add-initiator ig-id=”VB001_ESXI01″ initiator-name=”VB001_ESXI01-HBA0″ port-address=”20:00:00:25:xx:xx:xx:6F”

add-initiator ig-id=”VB001_ESXI01″ initiator-name=”VB001_ESXI01-HBA1″ port-address=”20:00:00:25:xx:xx:xx:6F”

add-initiator-group ig-name=”VB001_ESXI02″ parent-folder-id=”/VDICluster”

add-initiator ig-id=”VB001_ESXI02″ initiator-name=”VB001_ESXI02-HBA0″ port-address=”20:00:00:25:xx:xx:xx:7F”

add-initiator ig-id=”VB001_ESXI02″ initiator-name=”VB001_ESXI02-HBA1″ port-address=”20:00:00:25:xx:xx:xx:7F”

Any help on provisioning net new VMware host to XtremIO is appreciated.

Reply
1 Solution

Accepted Solutions
Highlighted
2 Bronze

Re: XtremIO CLI

Jump to solution

Hi Rideout421!

I'm not Dell EMC, but I do know the XtremIO VERY well from when I used to work there. The XtremIO CLI can be done various ways. The common way most interact with the CLI is either via SSH to the XMS on each individual array/cluster and run your commands there, through the CLI tab on the GUI for each cluster, or via a linux host leveraging a user account that logins via SSH key.

Are your multiple arrays/clusters managed by the same XMS? If so, then this will be easy for you. I would start with the following command:

show-clusters

xmcli (admin)> show-clusters

Cluster-Name          Index State  Gates-Open Conn-State Num-of-Vols Num-of-Internal-Volumes Vol-Size UD-SSD-Space Logical-Space-In-Use UD-SSD-Space-In-Use Total-Writes Total-Reads Stop-Reason Size-and-Capacity

xio001 1     active True       connected  303         0                       390.124T 91.468T      147.998T             80.405T             12.807P      5.758P      none        6X20TB

xio002 2     active True       connected  282         0                       390.176T 91.468T      141.544T             75.753T             8.183P       10.114P     none        6X20TB

xio003 3     active True       connected  33          0                       80.256T  91.468T      30.953T              14.532T             774.359T     4.350P      none        6X20TB

xio004 4     active True       connected  20          0                       70.885T  91.468T      39.233T              19.618T             2.414P       533.165T    none        6X20TB

You will see that each cluster is associated with an index ID (or cluster ID). In my example above, xio001 is cluster ID 1. If I want to issue a command against that cluster, I would do the following:

add-initiator-group cluster-id=1 ig-name=”VB001_ESXI02″

If you are able to, I would worry about tagging the initiator group, initiators, volumes, etc when you are back in the GUI. It's easier and faster that way. In version 4.x of code, there are no folders so the parent-folder command you referenced would not be valid.

Let me know if this helps! If you're clusters have their own XMS, then you may need to SSH to each XMS to run your commands. If that is the case, you will not need the cluster-id property when running commands there.

View solution in original post

Reply
7 Replies
Highlighted
2 Bronze

Re: XtremIO CLI

Jump to solution

Hi Rideout421!

I'm not Dell EMC, but I do know the XtremIO VERY well from when I used to work there. The XtremIO CLI can be done various ways. The common way most interact with the CLI is either via SSH to the XMS on each individual array/cluster and run your commands there, through the CLI tab on the GUI for each cluster, or via a linux host leveraging a user account that logins via SSH key.

Are your multiple arrays/clusters managed by the same XMS? If so, then this will be easy for you. I would start with the following command:

show-clusters

xmcli (admin)> show-clusters

Cluster-Name          Index State  Gates-Open Conn-State Num-of-Vols Num-of-Internal-Volumes Vol-Size UD-SSD-Space Logical-Space-In-Use UD-SSD-Space-In-Use Total-Writes Total-Reads Stop-Reason Size-and-Capacity

xio001 1     active True       connected  303         0                       390.124T 91.468T      147.998T             80.405T             12.807P      5.758P      none        6X20TB

xio002 2     active True       connected  282         0                       390.176T 91.468T      141.544T             75.753T             8.183P       10.114P     none        6X20TB

xio003 3     active True       connected  33          0                       80.256T  91.468T      30.953T              14.532T             774.359T     4.350P      none        6X20TB

xio004 4     active True       connected  20          0                       70.885T  91.468T      39.233T              19.618T             2.414P       533.165T    none        6X20TB

You will see that each cluster is associated with an index ID (or cluster ID). In my example above, xio001 is cluster ID 1. If I want to issue a command against that cluster, I would do the following:

add-initiator-group cluster-id=1 ig-name=”VB001_ESXI02″

If you are able to, I would worry about tagging the initiator group, initiators, volumes, etc when you are back in the GUI. It's easier and faster that way. In version 4.x of code, there are no folders so the parent-folder command you referenced would not be valid.

Let me know if this helps! If you're clusters have their own XMS, then you may need to SSH to each XMS to run your commands. If that is the case, you will not need the cluster-id property when running commands there.

View solution in original post

Reply
Highlighted
2 Bronze

Re: XtremIO CLI

Jump to solution

Thank you blueflashylights and scotthoward, When I ran a show-initiator-groups I can see multiple Cluster-Names in the output. (set-context cluster-id="name") I plan to specify the cluster name before running commands against each of our X bricks. Thank you both information was very helpful.

0 Kudos
Reply
Highlighted
7 Thorium

Re: XtremIO CLI

Jump to solution

you don't have access to XMS (GUI) to perform these tasks ?   Yes, i love symcli but XMS is so much easier to use than Unisphere for VMAX.

Reply
Highlighted
2 Bronze

Re: XtremIO CLI

Jump to solution

You can access xmcli using SSH with Putty. Connect to your XMS using putty. The connection server will ask for authentication twice. The first time is xmsadmin with Xtrem10 default password. I found default password online using Google. Once you authenticate as xmsadmin it will prompt you again for your local account user name and password. Once authenticated the second time with your local account xmcli comes up in putty just as if you were in the GUI using the CLI tab to the far right. I prefer putty for my logging capability to save all sessions output. You can easily use putty, super putty or your preferred ssh tool. One thing I do with putty is go to my connections section and the data field to add xmsadmin as the default user login. Gets me out of having to type xmsadmin on connection every time.

I do all provisioning work using CLI. This is my first time provisioning on XtremIO. I was looking to get some coding advice on xmcli. Using GUI for anything other than performance metrics is to many clicks. All provisioning is done using Putty SSH session or sessions.

Anyone with XtremIO CLI provisioning experience please weigh in on my original query.


Thank you DECN

0 Kudos
Reply
Highlighted
7 Thorium

Re: XtremIO CLI

Jump to solution

good luck, you will quickly discover that XMS cli is clunky as heck. If i were to spent that much effort i would look into using REST instead. To each his own.

0 Kudos
Reply
Highlighted
3 Silver

Re: XtremIO CLI

Jump to solution

As dynamox has already said, using the GUI is normally the option way with XtremIO.

That said, the commands you've got are mostly correct - the only mistake is that presuming you're on version 4.x, the "parent-folder-id" option no longer exists as folders has been removed and replaced with tags. You can use the equivalent "tag-list" option, or just add the tags later.  If you are running something less than 4.0, then what you're got is correct.

If your XMS is only managing a single array, then there's no need to specify which array you want the commands to occur on. If the XMS is managing multiple arrays, then you'll need to specify which array you're making changes on - and there's two ways to do that.

For both options, first use the "show-clusters" command to get the exact name of the cluster (or the "index", you can use either).  Then you can either add   cluster-id="name"  to all of the commands you run, or you can just run :

set-context cluster-id="name"

This will cause all future commands to apply only to that one cluster, up until you re-run set-context, or you logout of the CLI.

Reply
Highlighted
2 Bronze

Re: XtremIO CLI

Jump to solution

Change day made it. Provisioning to XtremIO was a breeze. I was advised by colleges and people in this thread that XMS CLI was not the best command interface to use. With that said I’d like to share the process I followed to provision net new ESXi Host.

Process as follows

  • Zone your Host first
  • Access XtremIO GUI move to initiators tab and Discover new initiators
  • Once discovered you can double click appropriate initiator group and your WWN's show in a drop down and can be easily added using your naming convention and selecting the WWN from the drop down.

FYI there was a group adds but I don't see that working because WWNs are unique, looked at that option but didn't see the use case.

Overall the consensus with XtremIO that I had relayed to me by multiple folks is just use the GUI and sometimes you will find that is even a pain. I did not experience any pain points on my first run however I take advise from those before me cause if I didn't I wouldn't be where I am today.

PowerPath multi path checks on the agenda for the day. Everyone have a great day I am off to powermt

0 Kudos
Reply