Highlighted
SKOIR1
1 Copper

XtremIO: FC Error Link Failure

Jump to solution

When I run this command in every XIO, it always shows parameter Link-Failure count =1. What does it imply? What issue can cause what error for these parameters? A brief note would be great. Thanks.

xmcli (idigit)> show-targets-fc-error-counters                                                                                                                              

Name       Index Cluster-Name Index Dumped-Frames Sync-Loss Signal-Loss Invalid-Crc Link-Failure Prim-Seq                                                               

X1-SC1-fc1 1     XIO                  1               0                       0              0                     0                1                 0                                                                         

X1-SC1-fc2 2     XIO                  1               0                       0              0                     0                1                 0                                                                         

X1-SC2-fc1 5     XIO                  1               0                       0              0                     0                1                 0                                                                        

X1-SC2-fc2 6     XIO                  1               0                       0              0                     0                1                 0  

Tags (2)
1 Solution

Accepted Solutions
houdem
1 Copper

Re: XtremIO: FC Error Link Failure

Jump to solution

Hello iDigIT,

Adding onto what ChrisPy noted - When the cluster is first created, it is expected that a single link failure would be accrued during the initialization process.

A single instance of link failure should not be indicative of any port or SAN issues.

View solution in original post

4 Replies
ChrisPy2
1 Copper

Re: XtremIO: FC Error Link Failure

Jump to solution

It shows that historically there was a failure that caused the link to go down. With it only being 1 and on all of the links I wouldn't worry. If it was a high number it could indicate a flapping port. One thing to keep in mind also is that it is a historic value so it could be very old.

SKOIR1
1 Copper

Re: XtremIO: FC Error Link Failure

Jump to solution

Thanks ChrisPy! How can I clear the historic values?

houdem
1 Copper

Re: XtremIO: FC Error Link Failure

Jump to solution

Hello iDigIT,

Adding onto what ChrisPy noted - When the cluster is first created, it is expected that a single link failure would be accrued during the initialization process.

A single instance of link failure should not be indicative of any port or SAN issues.

View solution in original post

dunnel1
1 Copper

Re: XtremIO: FC Error Link Failure

Jump to solution

iDigIT

             there is no current way to clear these counters from CLI. As far as I am aware the only way to clear the counters would be via a reboot of the relevant SCs but wouldn't advise this as it is unneccesary seeing as there is no indication of a current link problem and is likely present since cluster initialization time as houdem already stated...hope this helps.