
UNSOLVED
Endpoint setting
Hi experts ....
I am getting confused about endpoint setting ... please help..
I found below in Doc ... ( https://support.emc.com/docu61787_Data-Domain-Operating-System-5.7.1-Administration-Guide.pdf?language=en_US )
The switchover to a secondary port is not an automatic operation. You must
manually switch the VTL device to the secondary ports if the primary ports become unavailable.
This means If Primary endpoint failed , Secondary need to kick in manually ?Fail over will not occur auto ?
What about NPIV enabled ... if using NPIV, will failover happen automatically ?
Also if failOver does not happen how to switchover to secondary ?
Woulld this be this ?
# scsitarget endpoint use XXXXXX secondary
# scsitarget endpoint use XXXXXXX primary
Or Disable endpoint in issue from GUI ..
thanks !
aya
Responses (4)
Solutions (0)
richbinstead
62 Posts
1199
0
Posted August 1st, 2016 02:00
Hi Aya,
The command for DDOS 5.6.x is as follows:
========================================================
vtl group use
[vtl {all | changer | drive }]
{primary | secondary}
Switch the ports in use in a group or library to the primary or secondary port list
========================================================
cheers, RIch.
Reply

richbinstead
62 Posts
1199
0
Posted July 29th, 2016 03:00
Hi Aya,
I engaged one of my colleagues to assist with these questions are they are more proficient in VTL than I. Here is what they had to say:
With DDOS 5.7.x and NPIV, the failover will happen automatically. This is because you can configure a virtual WWPN for NPIV to use.
Without DDOS 5.7.x and NPIV, the failover has to happen manually as you mentioned above.
> Also if failOver does not happen how to switchover to secondary ?
> Woulld this be this ?
> # scsitarget endpoint use XXXXXX secondary
> # scsitarget endpoint use XXXXXXX primary
Those are the correct steps for manual failover. You would then need to configure the backup software to use the new primary path.
cheers, Rich.