Announcement Banner
UNSOLVED

scott.schroeder

updated

14 years ago

0

45734

May 23rd, 2012 08:00

Update Task fails with "Invalid Package Path"

I have OME 1.0.1.1253 and Repository Manager 1.4.113 running on a Win Svr 2008 R2 Enterprise x64 server. Both are installed to D:\program files (x86)\Dell

I used RM to create a OpenManage Essentials Repository. The repository manager file is D:\Program Files (x86)\Dell\Dell Repository Manager v1.4.113\Dell Server Repository\OMSE_Repository_Test_SAS_20120523.xml. The Active Catalog shows this path with Source Type: RepositoryManager, Release ID: bdc8f803, and Release Date: 05/23/2012. Newer version available: No.

I create an Update Task for one server (the BIOS 1.9 update) and apply it with "Run Now". Very rapidly it completes with 100% and a green check. When I look at the details, I see:

Uploaded 0 of 1 packages to D:\Program Files (x86)\Dell\SysMgt\Essentials\SystemUpdate\Packages on SERVERNAME. - Complete.

Result for Target: Invalid package path FOLDER00178801M/1/BIOS_1V7NP_WN32_1.9.0.EXE

I have tried the same procedure for other updates and get the same result.

If I use ftp://ftp.dell.com/catalog/catalog.cabas the catalog source, the same update fails, but differently. It says "Uploaded 1 of 1 packages to D:\Program Files (x86)\Dell\SysMgt\Essentials\SystemUpdate\Packages on SERVERNAME. - Failed.

Result for target: Package uploaded ftp://ftp.dell.com/FOLDER00178801M/1/BIOS_1V7NP_WN32_1.9.0.EXE. EXEException message: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

Any ideas? Thanks.

  • DELL-Abhijit P

    Community Manager

    •

    711 Posts

    2382

    0

    Posted May 23rd, 2012 09:00

    Hi,

    Thanks for your post. One quick thing to check would be the to verify the account you are using to login to OME is part of OMEAdministrators group and has full permissions to access the path "D:\Program Files (x86)\Dell\SysMgt\Essentials\SystemUpdate\Packages"

    Regards

    Abhijit

  • 2382

    0

    Posted May 24th, 2012 00:00

    Yes, the account I logged into the server with is a member of OMEAdminstrators, and I had also added this account with full control to the entire folder structure under D:\Program Fiels (x86)\Dell. Still does not work.

  • DELL-Abhijit P

    Community Manager

    •

    711 Posts

    2382

    0

    Posted May 24th, 2012 08:00

    Thanks for the updates. For both cases the error is for the same update. Is it possible for you to try any other update package. That will tell us if the error is related to the catalog entry for this specific update package.

    Regards

    Abhijit

  • 2382

    0

    Posted May 24th, 2012 08:00

    There are five update packages available, and all fail the same way. Is the fact that OME not installed to the C: drive in any way a problem? I have confirmed that the account I'm using is in OMEAdministrators, and that that group and the account itself have full control all the way through the folder structure, down to the individual package files.

  • DELL-Abhijit P

    Community Manager

    •

    711 Posts

    2382

    0

    Posted May 24th, 2012 10:00

    Thanks for the updates. OME non default install path should not be an issue. For Repository Manager, it looks like OME cannot find the package in the path listed in the catalog. Can you verify if the repository generated is in the same folder as the catalog?

    For ftp it may be downloading the package successfully but the file verification may be failing. Can you check if you see the downloaded packages under "Packages" folder?

    Regards

    Abhijit

  • gbstjem

    1 Rookie

    •

    13 Posts

    2379

    0

    Posted August 29th, 2012 20:00

    Has this been resolved? I have exactly the same issue.

    I've created a repository using RM, downloaded the files but if I try and update a system using OME i get the Invalid package path error. I can confirm that files exist in the path shown and that the account i'm using has full access to the directory. I get this no matter what package i try to install, i have tried multiple packages and a single package with the same results.

  • DELL-Abhijit P

    Community Manager

    •

    711 Posts

    2379

    0

    Posted August 30th, 2012 08:00

    Hi,

    Thanks for your post. Few more questions for you.

    Are you running repository manager and the updates from OME server directly or are you doing it from remote machine using web interface?

    Can you check if OME website is part of the trusted sites in your browser security settings?

    Also check if the account you are using has full permissions not just to the source folder where the updates and catalog are located but also to the system updates folder on OME machine (C:\Program Files (x86)\Dell\SysMgt\Essentials\SystemUpdate)

    After all these are verified, you can try importing the catalog again.

    Regards

    Abhijit

  • gbstjem

    1 Rookie

    •

    13 Posts

    2379

    0

    Posted August 30th, 2012 22:00

    Hi,

    I am running repository manager and OME directly on the server and using a Domain Admin account so don’t believe it is a permissions problem. I’ve confirmed that the account I am using has full control to the C:\Program Files (x86)\Dell\SysMgt\Essentials\SystemUpdate folder. The OME site has been added to the trusted sites in browser settings.

    I have tried using the online dell online catalog to do system update but I get the following error. Package unavailable ftp.dell.com/.../Network_Driver_TJPWC_WN32_3.00.08_A00.exe  (I believe this is caused by our proxy server which is why we are trying to use a local repository)

    I have just tried to import the catalog created with Repository manager again and have tried to update a single driver on a server and get the same results. "Invalid Package path"

    Just to confirm my environment, I created the repository using Dell Repository Manager 1.4.113 (Server) I selected create-Dell OpenManage Essentials Repository, I saved the catalog file and update packages to a folder on the D: drive of the server. I then imported the saved catalog file in OpenManage Essentials.

    Regards

  • DELL-Abhijit P

    Community Manager

    •

    711 Posts

    2379

    0

    Posted August 31st, 2012 08:00

    Thanks for the updates.

    For the online catalog proxy issue, have you tried configuring proxy settings located under the Preferences tab? You can use the Test connection button to verify the connectivity. That might allow you to use the online repository while we sort out the local repository issue.

    Regarding local repository, can you check if the domain admin accout is part of local administrators group in OME? Sometimes file permissions are specific to local administrators and don't get transferred to domain administrator accounts unless that account it explicitly added as local administrator.

    You are doing everything right for importing the catalong from repository manager.

    Regards

    Abhijit

  • gbstjem

    1 Rookie

    •

    13 Posts

    851

    0

    Posted September 5th, 2012 23:00

    Ok, I have tried this with a different Proxy server (one does that not scan downloads) and this has worked using the FTP site, the local repository is still not working. Using the local repository is the preferred solution.

    Added account to local administrators group, OME administrators grop on the OME server as suggested but still get the following error when trying to push out an update.

    "Invalid package path FOLDER00412796M/1/Network_Driver_H8HTP_WN32_17.2.0_A00.EXE FOLDER00409443M/1/Network_Driver_TJPWC_WN32_3.00.08_A00.EXE"

    Is there a way to check that this path is actually referring to "D:\Dell Updates\FOLDER00412796M\1" which is where i have created the repository and not "C:\Program Files (x86)\Dell\SysMgt\Essentials\SystemUpdate\Packages" where the packages are saved using the FTP catalog??