I've upgraded to the latest version of InsightIQ--4.1.1.3 and tried using it to monitor a new isilon running OneFS 8.0.0.3. Attempting to add the cluster produces the error:
"The Specified cluster is running an unsupported version of OneFS..." and directs me to the compatibility guide. The compatibility guide does not list granular versions simply major 8.0.x and claims to support it.
I've seen this before when you don't have your user that InsightIQ is using to access your cluster set up correctly.
For example, on each of my Isilon clusters, I created a "LOCAL:System" user called "insightiq" and added it to the "AuditAdmin" role (since that role has read-only privileges). I specified this user in InsightIQ to monitor my Isilon cluster(s). I believe if you create a user but don't assign it a role, you'll get the error you're seeing.
You should also make sure you have an NFS export for /ifs/.ifsvar/modules/fsa if you have removed the default /ifs NFS share.
Did you happen to add the clusters net-new on version 8.0.0.3+ or were you monitoring them with InsightIQ already on an older version and performed an upgrade to 8.0.0.3?
You are correct and I noted it in my first post. However, the error I am receiving specifically states that InsightIQ does not support the OneFS version running on the cluster. I am opening an SR as soon as I can because clearly it should be working.
I get one of two errors, depending on if the user is in a role or not:
a.
InsightIQ was unable to connect to the cluster at 10.139.10.10 with the specified credentials. Please make sure the specified InsightIQ username and password are correct. If this error persists, make sure that the InsightIQ user is enabled on the cluster.
gvaidman
20 Posts
2367
0
Posted March 17th, 2017 11:00
I've seen this before when you don't have your user that InsightIQ is using to access your cluster set up correctly.
For example, on each of my Isilon clusters, I created a "LOCAL:System" user called "insightiq" and added it to the "AuditAdmin" role (since that role has read-only privileges). I specified this user in InsightIQ to monitor my Isilon cluster(s). I believe if you create a user but don't assign it a role, you'll get the error you're seeing.
You should also make sure you have an NFS export for /ifs/.ifsvar/modules/fsa if you have removed the default /ifs NFS share.