Announcement Banner

icculus203

updated

10 years ago

0

3346

March 16th, 2017 13:00

Does InsightIQ 4.1.1.3 not support OneFS 8.0.0.3?

I've upgraded to the latest version of InsightIQ--4.1.1.3 and tried using it to monitor a new isilon running OneFS 8.0.0.3.  Attempting to add the cluster produces the error:

"The Specified cluster is running an unsupported version of OneFS..." and directs me to the compatibility guide.  The compatibility guide does not list granular versions simply major 8.0.x and claims to support it.

Is this version not yet supported?

  • gvaidman

    20 Posts

    2367

    0

    Posted March 17th, 2017 11:00

    I've seen this before when you don't have your user that InsightIQ is using to access your cluster set up correctly.

    For example, on each of my Isilon clusters, I created a "LOCAL:System" user called "insightiq" and added it to the "AuditAdmin" role (since that role has read-only privileges).  I specified this user in InsightIQ to monitor my Isilon cluster(s).  I believe if you create a user but don't assign it a role, you'll get the error you're seeing.

    You should also make sure you have an NFS export for /ifs/.ifsvar/modules/fsa if you have removed the default /ifs NFS share.

  • Yan_Faubert

    117 Posts

    2367

    0

    Posted March 17th, 2017 06:00

    It is supported.  I have IIQ 4.1.1.3 and OneFS 8.0.0.3 and it's working fine.  You might have to involve support to dig deeper into the issue.

    iiq2.PNG.png

    iiq.PNG.png

  • 2367

    0

    Posted March 17th, 2017 06:00

    Thanks.  I'll open a SR.


    Did you happen to add the clusters net-new on version 8.0.0.3+ or were you monitoring them with InsightIQ already on an older version and performed an upgrade to 8.0.0.3?

  • 2367

    0

    Posted March 17th, 2017 10:00

    You are correct and I noted it in my first post.  However, the error I am receiving specifically states that InsightIQ does not support the OneFS version running on the cluster.   I am opening an SR as soon as I can because clearly it should be working.

  • sjones51

    252 Posts

    2367

    0

    Posted March 17th, 2017 10:00

    Hi icculus203,

    This is also confirmed in the Isilon Support and Compatibility Guide

    https://support.emc.com/docu44518

  • Yan_Faubert

    117 Posts

    2367

    0

    Posted March 17th, 2017 12:00

    cluster was added net-new.

  • 2367

    0

    Posted March 20th, 2017 11:00

    That did the trick.  I did not have the user added to any roles--added to AuditAdmin and it worked.  Thanks!

  • 2097

    0

    Posted August 27th, 2019 16:00

    No matter what I do, I cannot connect the isilon to insightIQ.  They are on the same subnet, so no firewall.  

    Please help

     

    [administrator@localhost ~]$ curl --fail -k https : //  10.139.10.10 : 8080 /platform/1/cluster/identity

     

    {

    "description" : "Isilon Gen 6",

    "logon" :

    {

    "motd" : "",

    "motd_header" : ""

    },

    "name" : "isilon-sna01"

    }

    You have new mail in /var/spool/mail/administrator

     

     

     

     

     

    isilon-sna01-1# isi auth mapping token insightiq

                       User

                           Name: insightiq

                            UID: 2001

                            SID: S-1-5-21-257375888-38551132-3552126884-1001

                        On Disk: 2001

                        ZID: 1

                       Zone: System

                 Privileges: ISI_PRIV_LOGIN_CONSOLE

                             ISI_PRIV_LOGIN_PAPI

                             ISI_PRIV_LOGIN_SSH

                             ISI_PRIV_SYS_TIME

                             ISI_PRIV_SYS_UPGRADE

                             ISI_PRIV_ANTIVIRUS

                             ISI_PRIV_AUDIT

                             ISI_PRIV_CERTIFICATE

                             ISI_PRIV_CLOUDPOOLS

                             ISI_PRIV_CLUSTER

                             ISI_PRIV_DEVICES

                             ISI_PRIV_EVENT

                             ISI_PRIV_FILE_FILTER

                             ISI_PRIV_FTP

                             ISI_PRIV_HARDENING

                             ISI_PRIV_HDFS

                             ISI_PRIV_HTTP

                             ISI_PRIV_JOB_ENGINE

                             ISI_PRIV_LICENSE

                             ISI_PRIV_MONITORING

                             ISI_PRIV_NDMP

                             ISI_PRIV_NETWORK

                             ISI_PRIV_NFS

                             ISI_PRIV_NTP

                             ISI_PRIV_QUOTA

                             ISI_PRIV_REMOTE_SUPPORT

                             ISI_PRIV_SMARTPOOLS

                             ISI_PRIV_SMB

                             ISI_PRIV_SNAPSHOT

                             ISI_PRIV_SNMP

                             ISI_PRIV_STATISTICS

                             ISI_PRIV_SWIFT

                             ISI_PRIV_SYNCIQ

                             ISI_PRIV_VCENTER

                             ISI_PRIV_WORM

              Primary Group

                           Name: Administrators

                            GID: 1544

                            SID: S-1-5-32-544

                        On Disk: S-1-5-32-544

    Supplemental Identities

                           Name: Authenticated Users

                            SID: S-1-5-11

     

    isilon-sna01-1# isi auth roles modify InsightIQRole --add-priv ISI_PRIV_QUOTA

    isilon-sna01-1# isi auth roles modify InsightIQRole --add-priv ISI_PRIV_NS_IFS_ACCESS

    isilon-sna01-1# isi auth roles modify InsightIQRole --add-priv ISI_PRIV_NS_TRAVERSE

    isilon-sna01-1# isi auth roles modify InsightIQRole --add-priv ISI_PRIV_SNAPSHOT

    isilon-sna01-1# isi auth roles modify InsightIQRole --add-priv ISI_PRIV_SMARTPOOLS

    isilon-sna01-1# isi auth roles modify InsightIQRole --add-user insightiq

     

     

     

     

     

    isilon-sna01-1# isi_test_pam -u insightiq -p

    Got username insightiq

     

     

    I get one of two errors, depending on if the user is in a role or not:

    a. 

    InsightIQ was unable to connect to the cluster at 10.139.10.10 with the specified credentials. Please make sure the specified InsightIQ username and password are correct. If this error persists, make sure that the InsightIQ user is enabled on the cluster.

    b.

    Add Cluster
    Error
    Error getting cluster configuration. Please try again.
     
     
    InsightIQ Version:

    4.1.3.88

    OneFS Version: 8.1.0.4)