3rd time i have tried posting this question, not sure why it keeps marking it as spam?! anyway....
We have 2 x 8 node clusters running 9.1.0.4, each cluster has 4 CAVA Windows servers available to them.
However every few minutes we are getting errors logged with
ID Started Sev Message ------------------------------------------------------------------------ 82315 07/12 15:19 W Resolved: The antivirus software on the server Cluster1Cava01.domain connected to node 3 has errors or is working improperly. Please check the CEE installation guide and the antivirus software vendor's documentation for proper setup.
I have checked the CAVA servers
No obvious errors are being reported on the WIndows servers
AV is working on them as expected
Created a test virus file using the EICAR test file which prompted correct alerts
also checked the Isilon
CAVA servers show as enabled
Each node shows connections to them
so my questions to you all are
What else can I check for this?
What have I missed?
My Guess is that Dell Support won't be able to help as the AV isn't provided by them
So further update - one thing that makes a BIG difference is an old requirement from the VNX - as its related to the Windows Server Caching the Folder it has been by DELL as definitely still relevant - it was not in the earlier Isilon Config guides - might be in newer later versions.
Basically the Windows Server is using a cached view of the Folder - so if files are changed / deleted rapidly the cache is out of date and we get the File not found error - this is sent back to the Isilon as a Windows CEE "event" and triggers an AV Server Warning / Alert.
Still looking into the Health state of some of the AV Servers dropping to POOR - and how to spread the CAVA AV Workload as some servers seem to get saturated but there seems to be no way to change the way the Isilon distribute the workload - or increase the 5 Threads that each Isilon node starts to the 4 Target CAVA Servers. This means in our case with not all nodes being front end and engaging in the CAVA AV we only have 4 Active Isilon Nodes (with 5 threads) * 4 AV Server connections
To avoid this condition, you must disable the directory cache on the machines on which CAVA and AV engines are running by using the following procedure:
1. Open the Windows Registry Editor and navigate to HKLM\System\CurrentControlSet\Services\LanmanWorkstation \Parameters. 2. Right-click Parameters and select New > DWORD Value. 3. For the new REG_DWORD entry, type a name of DirectoryCacheLifetime. 4. Set the value to 0 to disable DirectoryCacheLifetime. 5. Click OK. 6. Restart the machine
DELL-Sam L
Community Manager
•
8095 Posts
•
34547 Points
1273
1
Posted July 12th, 2021 16:00
Hello NotStopIsilonProblems,
Have you looked at chapter 2 of Dell EMC CEE Using the Common Event Enabler on Windows Platforms guide? https://dell.to/3ebtFU1