
UNSOLVED
E
equintana1
1 Rookie
•
22 Posts
0
2633
June 7th, 2006 18:00
NMI display XBSA Error: (BSAGetObject)
Hi,
The problem is when we try to restore the informix database with "onbar -r" command, the error is send.
Environment
- NetWorker 7.2.1
- NMI 2.0
- Informix 9.20
- Solaris 8
NetWorker is backing up the informix database correctly (schedule backup), but the problem is when we want to do the recover. We discover that NetWorker failed to restore when is a schedule backup. Becuase in the bar_act.log onbar write the save set was backup fine, but in the NetWorker index is store with diferent save
Onbar log
INFORMIX:/test/rootdbs
nsrinfo -v -s -n informix -X All
INFORMIX:/test/1
Obviusly, when I onbar want to recover the database, the error is that XBSA doesnt get the object.
We tested when we modified the ixbar.x file to restore in point of the time, but is the same error.
Schedule Backup
------------
2006-06-06 19:24:16 15212 15211 /opt/informix/bin/onbar_d -b -L 0
2006-06-06 19:24:17 15212 15211 Begin level 0 backup rootdbs.
2006-06-06 19:24:17 15212 15211 Successfully connected to Storage Manager.
2006-06-06 19:24:19 15212 15211 Completed level 0 backup rootdbs (Storage Manager copy ID: 1149639857 1149639858).
2006-06-06 19:24:19 15212 15211 Begin backup logical log 15.
2006-06-06 19:24:19 15212 15211 Successfully connected to Storage Manager.
2006-06-06 19:24:21 15212 15211 Completed backup logical log 15 (Storage Manager copy ID: 1149639859 1149639860).
2006-06-06 19:24:21 15212 15211 /opt/informix/bin/onbar_d complete, returning 0 (0x00)
2006-06-06 19:41:26 15307 15306 /opt/informix/bin/onbar_d -b -L 0
--------------
Onbar -r
-----------
2006-06-06 18:30:34 14400 14398 /opt/informix/bin/onbar_d -r
2006-06-06 18:30:34 14400 14398 Successfully connected to Storage Manager.
2006-06-06 18:31:22 14400 14398 Begin salvage for log 11.
2006-06-06 18:31:22 14400 14398 Completed salvage of logical log 11.
2006-06-06 18:31:22 14400 14398 Successfully connected to Storage Manager.
2006-06-06 18:31:23 14400 14398 XBSA Error: (BSAGetObject) Backup object does not exist in Storage Manager.
2006-06-06 18:31:23 14400 14398 Object information: bar_objdesc
obj_id 0 obj_name 'rootdbs' obj_type 'R' act_id 0 act_type 2 act_status 0
act_start '2006-06-06 18:31:23' act_end '2006-06-06 18:08:48'
ins_time 0 rsam_time 0 level 0 copyid hi:lo 1149635328:1149635329 req_act_id 5
logstream 0 est_pages hi:lo 0:0 first_log 0 chpt_log 0 last_log 0
partial_flag 0 do_query 0 ins_sm_id 0 ins_sm_name ''
ins_verify 0 ins_verify_date '' restore order 0:0
objInfo ''
retry 0 in_catalog 0 in_bootfile 0 child_pid 0 child_state 0
bkup_host ''
2006-06-06 18:31:23 14400 14398 ON-Bar was unable to get backup record of rootdbs from storage manager.
2006-06-06 18:31:28 14400 14398 Due to the previous error, logical restore will not be attempted.
2006-06-06 18:32:48 14400 14398 /opt/informix/bin/onbar_d complete, returning 100 (0x64)
----
The problem is when we try to restore the informix database with "onbar -r" command, the error is send.
Environment
- NetWorker 7.2.1
- NMI 2.0
- Informix 9.20
- Solaris 8
NetWorker is backing up the informix database correctly (schedule backup), but the problem is when we want to do the recover. We discover that NetWorker failed to restore when is a schedule backup. Becuase in the bar_act.log onbar write the save set was backup fine, but in the NetWorker index is store with diferent save
Onbar log
INFORMIX:/test/rootdbs
nsrinfo -v -s -n informix -X All
INFORMIX:/test/1
Obviusly, when I onbar want to recover the database, the error is that XBSA doesnt get the object.
We tested when we modified the ixbar.x file to restore in point of the time, but is the same error.
Schedule Backup
------------
2006-06-06 19:24:16 15212 15211 /opt/informix/bin/onbar_d -b -L 0
2006-06-06 19:24:17 15212 15211 Begin level 0 backup rootdbs.
2006-06-06 19:24:17 15212 15211 Successfully connected to Storage Manager.
2006-06-06 19:24:19 15212 15211 Completed level 0 backup rootdbs (Storage Manager copy ID: 1149639857 1149639858).
2006-06-06 19:24:19 15212 15211 Begin backup logical log 15.
2006-06-06 19:24:19 15212 15211 Successfully connected to Storage Manager.
2006-06-06 19:24:21 15212 15211 Completed backup logical log 15 (Storage Manager copy ID: 1149639859 1149639860).
2006-06-06 19:24:21 15212 15211 /opt/informix/bin/onbar_d complete, returning 0 (0x00)
2006-06-06 19:41:26 15307 15306 /opt/informix/bin/onbar_d -b -L 0
--------------
Onbar -r
-----------
2006-06-06 18:30:34 14400 14398 /opt/informix/bin/onbar_d -r
2006-06-06 18:30:34 14400 14398 Successfully connected to Storage Manager.
2006-06-06 18:31:22 14400 14398 Begin salvage for log 11.
2006-06-06 18:31:22 14400 14398 Completed salvage of logical log 11.
2006-06-06 18:31:22 14400 14398 Successfully connected to Storage Manager.
2006-06-06 18:31:23 14400 14398 XBSA Error: (BSAGetObject) Backup object does not exist in Storage Manager.
2006-06-06 18:31:23 14400 14398 Object information: bar_objdesc
obj_id 0 obj_name 'rootdbs' obj_type 'R' act_id 0 act_type 2 act_status 0
act_start '2006-06-06 18:31:23' act_end '2006-06-06 18:08:48'
ins_time 0 rsam_time 0 level 0 copyid hi:lo 1149635328:1149635329 req_act_id 5
logstream 0 est_pages hi:lo 0:0 first_log 0 chpt_log 0 last_log 0
partial_flag 0 do_query 0 ins_sm_id 0 ins_sm_name ''
ins_verify 0 ins_verify_date '' restore order 0:0
objInfo ''
retry 0 in_catalog 0 in_bootfile 0 child_pid 0 child_state 0
bkup_host ''
2006-06-06 18:31:23 14400 14398 ON-Bar was unable to get backup record of rootdbs from storage manager.
2006-06-06 18:31:28 14400 14398 Due to the previous error, logical restore will not be attempted.
2006-06-06 18:32:48 14400 14398 /opt/informix/bin/onbar_d complete, returning 100 (0x64)
----
Responses (4)
Solutions (0)
- Looks fine (except that PATH and LD_LIBRARY_PATH lines are broken, but I guess that could be due to forum software). Do you already have a support case for this? Perhaps you wish to give it a try - at first glance everything looks fine. I assume also you don't use any username/password too so that should be fine as well... Sorry, no idea.
However I just saw this line:
The schedule backup doesnt create new index entry and
media database because the mminfo an nsrinfo doesnt have
this kind of backup.
In your first post you showed that backup works fine and restore fails. If backup works fine then there must be a entry in media database. It might be that it goes under wrong client name or something else, but record of backup you did must exists (if sucessful and it should be according to bar_act log you sent).Reply equintana1
1 Rookie
•
22 Posts
1429
0
Posted June 12th, 2006 14:00
Hi,
It´s not a cluster. The schedule backup doesnt create new index entry and media database because the mminfo an nsrinfo doesnt have this kind of backup. But I execute a manual backup and restore they are successful.
I reinstalled the NetWorker and MNI in the client, and reconfigure the NetWorker configuration (group, schedule, client, pool) but the error is the same
Regards
Equintan@Reply equintana1
1 Rookie
•
22 Posts
1430
0
Posted June 16th, 2006 02:00
Hi,
I opened a case because this problem is only in the production host, the customer has a developenment enviroment and it is backing up fine.
Thank you
regardsReply

ble1
6 Operator
•
14354 Posts
•
56186 Points
1429
0
Posted June 11th, 2006 06:00