Announcement Banner
UNSOLVED

schilling_43666e

updated

18 years ago

0

884

May 1st, 2008 07:00

Filtering issue, while trying to create a volume in Linux

Just pulled in 3 new luns on a Linux system that is using Powerpath 4.5.3. We are up to 37 volumes, listing as emcpowera through emcpowerbb. I am able to see all of the volumes using powermt display dev=all, and I can fdisk the new volumes, however when I try to run a pvcreate of the last two volumes, I get the following error:

Device /dev/emcpowerba1 not found (or ignored by filtering).
Device /dev/emcpowerbb1 not found (or ignored by filtering).

Not sure what filtering file to look at, we check /etc/lvm/lvm.conf removed all of our filter lines, still same issue. Does anyone have any ideas?
  • xe2sdc

    6 Operator

    •

    2831 Posts

    252

    1

    Posted May 1st, 2008 08:00

    Maybe the 3 new luns comes from another system ??
    Maybe they already have a partition table on them ??

    Can you please try to scratch the lun and run pvcreate again ??

    # dd if=/dev/random of=/dev/emcpowerba1 bs=1M count=8

    If you want you can also try to run pvcrate with "-vvvv" option.. Maybe it will give you better details on why it's failing.

    Message was edited by:
    Stefano Del Corno
  • 252

    0

    Posted May 1st, 2008 11:00

    That was it, ran the dd and this corrected the issue. Thanks