Announcement Banner

poet_imp

updated

17 years ago

P

poet_imp

4 Posts

1

5325

November 16th, 2009 11:00

CLI Command to enable access to a specific bookmark

I am trying to script a tape backup from a CDP copy of a database. I have already scripted the quiese and bookmark process on the database host. Now I need to access that bookmark on another host and can not for the life of me get the right syntax. I can access "latest" image but I can enable_image_access the bookmarked image directly.

Any assistance would bemuch appreciated.

  • JamesBEMC

    257 Posts

    2363

    0

    Posted November 16th, 2009 13:00

    So, typically it would be

    enable_image_access group="my group" image="my 10am image"

    Is this what you are trying?

    You can build the command interactively via the CLI.

    James

  • JamesBEMC

    257 Posts

    2363

    0

    Posted November 16th, 2009 12:00

    Hey there

    We have a RP CLI document, which you probably looked at on Powerlink

    http://powerlink.emc.com/km/live1/en_US/Offering_Technical/Technical_Documentation/300-009-433.pdf?

     Enable_image_access

    Parameters

    group=

    copy=

    [image=<...> | latest | prev | next]

    [time=HH:MM[:SS[:MICROS]] [DD/MM/YYYY]]

    [image_type=all | bookmark | user_bookmark | system_bookmark] (Default: all)

    [search_text=<...>]

    [exact_text=yes | no] (Default: yes)

    [scn= ]

    [max_search_range= months | weeks | days | hrs | mins | secs]

    [access_mode=logged | virtual_with_roll | virtual_without_roll] (Default: logged)

    So, an example would be

    enable_image_access group="my group" image=latest image_type=all

    Thanks

    James.

  • poet_imp

    4 Posts

    2363

    0

    Posted November 16th, 2009 12:00

    This much I have working. The problem is that I do not want the "latest" bookmark. I want the one I named during the time the database was quiesed.
  • poet_imp

    4 Posts

    2363

    0

    Posted November 16th, 2009 13:00

    Color me pink... It was not obvious to me that the image parameter would accept a bookmark name. It makes perfect sense, though. I was trying to use the Image_type, search_text and exact_text parameters and they were simply not supplying any joy. Thank you!
  • JamesBEMC

    257 Posts

    2369

    0

    Posted November 16th, 2009 13:00

    Cool!
  • achrom

    1 Rookie

    •

    10 Posts

    2369

    0

    Posted July 31st, 2018 03:00

    2018 RP 5 - to use specific bookmark  I have to use

    image=search_image image_type=user_bookmark  search_text='my bookmark label'

    with image='my bookmark label'  only -  I will get a syntax error

  • Idan

    4 Apprentice

    •

    675 Posts

    2369

    0

    Posted July 31st, 2018 04:00

    Can you please provide the full command you're trying to run and the output ?

    Granted you're providing the group and copy parameters, it should work.

    Regards,

    Idan

  • achrom

    1 Rookie

    •

    10 Posts

    2369

    0

    Posted July 31st, 2018 05:00

    enable_image_acces group=mytestgroup image=my_bookmark copy=mycopy access_mode=virtual_with_roll

    Error: Invalid ‘image’ parameter (with “,’ and without)

    If it will, I will get something like “your splitter does not support virtual access”

    RP 5.1c gen 5, vmax20k (something like rcm 6.0.19)

    I have to use parameters as I have provided (search, user, text) to get it working.

    I have run it now having copy accessible, it fails on syntax.

    BR

    Andrzej

  • Idan

    4 Apprentice

    •

    675 Posts

    2369

    0

    Posted July 31st, 2018 07:00

    Indeed you should have either ' or "" for the value of image.

    And the error you're getting on virtual access, that is expected as the VMAX2 splitter supports only logged access. Virtual access is supported with VNX, VNXe and Unity splitters.

    Hope that helps,

    Idan

  • achrom

    1 Rookie

    •

    10 Posts

    698

    0

    Posted August 2nd, 2018 01:00

    And the question how to use it in a batch:

    1. Force command "enable_image_access" to not ask for confirmation.

    2. If using a set of commands with plink (-m command_file), I have almost always incorrect usage error from RP, while from normal ssh session it is ok. Any advise? The sequence is: set bookmark, enable images with this bookmark, set direct access and pause transfer.