Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

2 Posts

46

April 5th, 2024 16:38

x15 R1, fails to charge

Hello all,

I bought my Alienware x15 R1 at the end of 2021. Lately, I've been having issues charging the laptop. It tells me to plug it in when it is already plugged in. The last few times I have switched up outlets, unfastened the charging cords, and wiggled the cord into the laptop and those had worked. But today it didn't work. And my laptop won't come back on. The charging cord is lit up which leads me to believe that is working. But even though the cord is all the way in, the laptop does not charge.

At this age is the battery life span coming to an end? What else can I do to solve this? 

Thank you for your time.

7 Technologist

 • 

12.1K Posts

April 5th, 2024 16:50

At 4 years old it certainly could be the battery but the fact that you "wiggled " the cord in the jack to get it working in the past leads me to believe the DC jack could be bad. That jack can be found here at CDRTD and at Amazon here and the instructions for replacing can be found at Parts-People here. Usually Parts-People carries such part but a Google search and a search at their site did not tun up that part.

isGoodTroubleshooting

1 Rookie

 • 

2 Posts

April 5th, 2024 23:44

@JOcean​ 

Thank you for your reply. 


I started looking up DC jack replacements, then I saw the USB-C (I think that's the name, I'm not that tech savvy) charging port. I used my wifes USB-C laptop charger, and my Alienware laptop was charging again. I am back on the laptop. That all leads me to believe the DC jack is messed up. I'll look to replace it.

Thank you for your prompt assistance!

7 Technologist

 • 

12.1K Posts

April 6th, 2024 02:40

@Cubskies​ Happy to help out!

No Events found!

Top