I want to shrink a FS which is about 5 TB of data but is sized incorrectly. I propose to use ndmpcopy ( possibly followed by emcopy ? )
I have looked at https://community.emc.com/docs/DOC-7832 and have downloaded the binary and created the user account ( 1 because its a copy internally from one datamover on one Celerra to the same datamover).
The source and destination fs are on a vdm, so I am prepending /root_vdm_x to the fs name to ensure the path is correct.
However I seem to be stopped with a problem actually connecting to the ndmp port on the datamover. So I am connecting to server_4 ( where the fs is). I get the following error message
./ndmpcopy IP address of DM:/root_vdm_10/test_source IP address of DM:/root_vdm_10/test_dest -sa ndmpcopy:password -da ndmpcopy:password -v -v -v -v
Creating NDMP connection.
Connecting to IP address of DM.
ERROR: comm.c:415 system call (connect): Connection refused
Could not open NDMP connection to host IP address of DM.
Has any one any thoughs on how from the cs I can verify from the server_logs either an error or the it is configured correctly.
Note we are using NDMP for general backups ( but a different username ) if this is relevant.
./ndmpcopy IP address of DM:/root_vdm_10/test_source IP address of DM:/root_vdm_10/test_dest -sa ndmpcopy:password -da ndmpcopy:password -sport 1000 dport 10000 -level 0 -v -v -v -v
Creating NDMP connection.
Connecting to IP address of DM
ERROR: comm.c:415 system call (connect): Connection refused
Could not open NDMP connection to host IP address of DM
it was a reasonable query. The reason I left it out is according to the documentation leaving them out makes the ports default to 10000.
Anyhow, is there any way I can either confirm from the client side the IP address/Port it is trying to connect to so I can verify on the cs that it is listening on that IP/Port pair ?
so that was from a linux box. I figured I did not like the putty so run the same thing from a putty client. I get a blank screen and no gibberish. Off to check that NDMP is properly running. The weird thing is I suspect it is as we are using NDMP to backup fs on this datamover.
Please double check your syntax. In the example you provided you have the source port set as 1000 as opposed to 10000. NDMP would not be able to connect on port 1000
./ndmpcopy IP address of DM:/root_vdm_10/test_source IP address of DM:/root_vdm_10/test_dest -sa ndmpcopy:password -da ndmpcopy:password-sport 1000 dport 10000 -level 0 -v -v -v -v
Creating NDMP connection.
Connecting to IP address of DM
ERROR: comm.c:415 system call (connect): Connection refused
Could not open NDMP connection to host IP address of DM
SAMEERK1
296 Posts
697
0
Posted February 10th, 2012 01:00
Hi,
Please check this file.. if the ndmp is commented out
$ cat /nas/server/slot_x/netd
#ndmp port=10000
Thanks
Sameer