Storage array is SCv2000, connected to 2 PC6224 switches.
2 R710 servers running Server 2019 in a HyperV Failover Cluster.
Each server has 2 BCM5709C iSCSI dual port cards.
Two ports are dedicated to the OS, two are dedicated to HyperV Virtual Switches.
I am having problems with a Server 2019 virtual machine receiving frequent iScsiPrt errors in the event log. Whenever there is any activity directed at the iSCSI targets, I get iScsiPrt event 20 followed immediately by iScsiPrt Event 34.
Event 20: Connection to the target was lost. The initiator will attempt to retry the connection.
Event 34: A connection to the target was lost, but Initiator successfully reconnected to the target. Dump data contains the target name.
QRQCMConnection CA Activate Failed: ControllerId=0x00034380 ObjId=0
Top Controller
I do not get these errors on the hosts, just the VM. I also do not get these errors on another VM using Server 2012R2.
I have rebuilt the VM from the ground up twice, once making sure to do all available Windows Updates, and again without doing any updates. The behavior is the same.
The behavior persists no matter which host is currently hosting the VM.
Does anyone have any suggestions on how to get these errors to clear? They seem to be having a performance impact on the SQL database attached to this VM.
If this is still actual, we've managed to solve this issue by disabling Recv Segment Coalescing on guest's Hyper-V Network Adapter designated for iSCSI traffic. This is Windows Server 2019/2022 feature. Guests with 2016 Server work fine.
As previously suggested by my colleague @DELL-Sam L, you may need to call into support so we can connect remotely to your SC3020, export a log and check the error.
Apologies that the support could not find the root cause. Probably best to provide more information about your configuration, storage model, OS and error messages, maybe the public users may have some solution for the issue.
DELL-Joey C
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell
Did I answer your query? Please click on ‘Mark as Accepted Answer’ if I did.
DELL-Sam L
Community Manager
•
8103 Posts
•
34571 Points
5431
0
Posted August 29th, 2019 13:00
Hello InboundTech,
What you will need to call into support so that we can remote into your SCv2000 & trace why that error is happing on your host.
Please let us know if you have any other questions.