Start a Conversation

Unsolved

P

2 Posts

948

September 9th, 2022 03:00

Trouble connecting Connectrix Brocade to Solarwinds SFTP /SCP Server

Hi, I'm having a really irritating problem downloading firmware to a Connectrix DS-650B fibre channel switch, hopefully someone can give me some pointers...

Using SolarWinds SCP/SFTP server on a laptop, but when I tried to run through the 'firmwaredownload -s' command, I ran through the wizard, entered the details of the SFTP server and got the message - "Failed to access sftp://scp:***@ / /release.plist  The server is inaccessible or firmware path is invalid. Please make sure the server name/IP address and firmware path are valid, the protocol and authentication are supported. It is also possible that the RSA host key could have been changed and please contact the System Administrator for adding the correct host key".

Did a bit of investigation and thought we'd fixed it on our test system.  We realized that we'd used multiple laptops with the same IP address as the SFTP server.  Fixed the issue by running the "sshutil delknownhosts -all" command on the switch and then the firmwaredownload worked just fine.  Very pleased.

Went to repeat the procedure on the Live system, and were dismayed to find that the 'sshutil delknownhosts -all' didn't fix the problem and we still get the same error message!

I've run out of ideas.  I think it is something to do with the RSA key stuff, but I don't know enough about it. The only difference I can see is when I run the "firmwaredownload -s" command successfully on the Test system, it reports that "Verifying if the public key authentication is available. Please wait.......The public key authentication is not available".

On the Live system where the download fails, it states " Verifying if the public key authentication is available. Please wait.......The public key authentication was successful".

I'm not sure what difference that would make, but its the only thing that I can see that is different.  We've ruled out general network issues, so have hit a bit of a dead end.  If anyone has any pointers, I'd be most grateful.

 

  

 

 

143 Posts

September 11th, 2022 22:00

Hi,

I agree with you that it has to do with “RSA key stuff” and would suggest to open a ticket with support  to have it investigated properly.

But I don’t understand why you use “firmwaredownload -s” on a DS-6505, normally the "-s" argument is used on a Director switch to upgrade the standby CP only, and not do the active CP. And the normal command to upgrade the departmental switch is without the “-s” argument. (Not saying that it will fix the issue, but rather stick to default procedure.)

As you say, it worked on the test system and not on the LIVE system, capture all the outputs you have or re-capture them again and collect supportsaves of the test and LIVE system and open a ticket.

You also can test the sfp/sftp connection with the "configupload" and "supportsave" commands.

Regards,

Ed

2 Posts

September 16th, 2022 06:00

Thanks for the suggestions - the supportsave command did output some interesting information. After much double checking, we resolved the issue.  Turns out there was an issue with a Windows firewall blocking it.  One of those issues where so many things had been changed and checked in an effort to get it working, that some values had crept back in when they were assumed to have been changed!

143 Posts

September 17th, 2022 00:00

Appreciate the time to give the feedback. Glad it is sorted for you.

Ed

No Events found!

Top