Start a Conversation

Solved!

Go to Solution

656

March 5th, 2024 20:57

NVMe SSD slot Generation compatibility?

I purchased a 4TB M.2 2280 PCIe Gen4 NVMe SSD to add to an Inspiron 15 7567 as a storage drive. The original hard drive was getting noisy and was replaced a few years ago with an appropriate form HD-size SSD and has been working fine.

I did not open the SSD package of the 'candidate' NVMe SSD yet pending confirmation it is 'compatible'.

How can I determine the 'Gen-level' era of the laptop SSD NVMe slot?

 

Will a Gen4 device work, and how poorly?

It was on sale for the same price everywhere. Finding an older (Gen3) 4TB device is possible, but maybe not locally (mail order)

I am mid-video-project and will run out of space on the boot SSD so I don't care I paid a little more for a Gen4 that was available and now in my grasp. If this laptop expires or retires the Gen4 SSD may live on for another purpose.

Thank for for any guidance or opinions you can offer.

March 18th, 2024 17:26

I got it done. Not exactly sure how, as it took me three installs...earlier problems were apparently some setting in BIOS that repeatedly set up NVMe as MBR after converting it to GPT.

Thank you for confirming the NVMe needing to be boot drive as that was the main obstacle.

 

10 Elder

 • 

23.9K Posts

March 5th, 2024 22:13

This is a pretty old system as far as NVMe support -- the best you'll get is half the speed of a PCIe 4 drive (and probably only half of half of it, as this system almost certainly runs the drive in GT2 mode.

There's no harm in installing a faster drive, but it won't perform anywhere near the level it's capable of.

March 5th, 2024 22:29

@ejn63​ 

Thank you. Sometimes one pays for lack of preparedness.

I still like the laptop & is has built-in Windows 11 prevention because of its age.

March 11th, 2024 17:22

New headache:

With the new NVMe SSD installed, if M.2 support is enabled, the laptop attempts booting from the blank NVMe device, not the SATA SSD that was previously the only bootable storage drive with OS. "Preparing Automatic Repair" appears for a few seconds then a black screen & restart

My son-in-law was the previous owner and we have both tried everything in BIOS. Looking in BIOS, the NVMe s/n appears correctly when M.2 support is checked, and is invisible (which is OK) when M.2 support is unchecked.

The boot options do not look familiar to my son-in-law, because I had installed Ubuntu years ago and there is a dual boot fork in the road. That stopped working or I stopped needing it so there is just a skeleton in the closet.

Changing RAID to AHCI checkbox changes the boot behavior. One option just results in a text display that no boot device is found, vs. the Automatic repair that restarts. Did not try the top options for neither AHCI nor RAID as the description looked undesirable.

Boot device & order seem to have no effect. Since I cannot boot to the Windows SATA SSD with M.2 device support selected, I cannot use the Crucial/Acronis cloning tool downloaded from Crucial.

I think I may have to setup a W10 ISO bootable USB drive to install W10 on the NVMe M.2 SSD, probably with the current SATA SSD support disabled, or physically removed, if that makes sense.

Either the BIOS assumes everyone who installs an NVMe SSD must want it to be the boot drive, or the Linux/Windows dual boot is making it behave strangely.

Trying the Secure vs non-secure boot UEFI options don't help either.

Am I making any sense my thinking W10 reinstallation onto the M.2 NVMe SSD is a solution?

Thank you

 

    

10 Elder

 • 

23.9K Posts

March 11th, 2024 17:28

You're correct that on most Dell systems that have both NVMe and SATA support, the NVMe device must be the boot drive. 

March 12th, 2024 22:19

Plug & Play has evolved into a Plug & Pound (table, laptop keyboard, whatever is nearby) adventure.

The 4 TB Crucial P3 Plus NVMe drive I chose does appear in the pre-check for compatibility and Crucial hardware scan of the laptop.

I tried the Windows media creation approach which was useless. It seems to have limited features.

I can't boot to W10 on the SATA with the M.2 device enabled in BIOS, as you confirmed.

So I ordered a W10 Home DVD package thinking that will be less crippled than download W10 options (Plan D).

Also ordered a larger SATA SSD for W10 reinstall if I cannot headbutt W10 onto the M.2 drive (Plan E.)

The SATA SSD & W10 DVD were a small expense compared to the NVMe SSD, and hopefully I get W10 AND SSD space restored. I deleted my Linux partition. I got some space temporarily. that way.

March 17th, 2024 07:50

OK.

I bought a Windows 10 DVD to install as the MS download seemed to have limitations...or I read incorrectly.

I got Windows reinstalled on the M.2 2280 NVMe 4 TB SSD, then Dell drivers updated.

The 4 TB (~3.6 TB actual) was installed by Windows as 2 TB MBR and 1.6 TB unallocated.

There are no options to apply (in Disk Management) the 1.6 TB that is unallocated, and the 2 TB MBR cannot be Extended for reasons that made sense (but I don't remember).

Is there a way to make the unallocated 1.6 TB space assignable as another non-bootable drive letter?

Thank you 

March 18th, 2024 00:00

OK, I learned MBR drives cannot be over 2 TB. Need GPT to access full drive capacity.

Converting from MBR to GPT seems generally a good way to lose data.

EASEUS claims to be able to do this without data loss. Paid for 1 month subscription & it completed in minutes, then told me to switch MB to UEFI. Can't access BIOS while running 3rd party s/w.

I could have wasted a partition for free (insult on top of injury).

Yesterday I had reinstalled W10 on the 2TB MBR partition and installed all Dell update drivers & firmware.

So today I seem to have verified the NVMe drive really did get changed to GPT & shows full size. 

I assume any Dell updates that were written (if any) to MB devices instead of SSD will remain updated. Dell scan will tell me what needs updating.

I appear to be successfully installing W10 on 3726 GB M.2 NVMe SSD.

What I'm worried about is what is proper BIOS (UEFI, secure?) setting to have this drive be seen at boot.

I had changed to legacy boot in BIOS at some point in this adventure to see 'familiar' boot device options, order, etc. if that makes zero sense it's because I've run in too many circles by this point.

Yes, at last, a question:

Do I have to choose specific BIOS boot settings (like UEFI & Secure) after W29 installs?

Thank you

No Events found!

Top