We have been working on setting up our primary Isilon cluster (12 NL400 nodes with OneFS 7.0.1.1) and have been having no issues until just recently. We prefer to use our active directory logins to perform administrative tasks in the WebUI but we realize this isnt working yet, so we have been using the admin user with its default password since we installed./configured the cluster. All of a sudden, beginning this past Wednesday evening we have been getting 'insufficient privilege' errors when logging in as admin in the WebUI, We receive an error message like the following when landing on the dashboard page:
Status
No privileges for this functionality
Your account does not include privileges for this specific OneFS functionality. Contact your systems administrator to request access.
and the URL changes to https://10.66.202.112:8080/OneFS#InsufficientPrivileges. Interestingly enough there are a couple of the pages we can get into without error, but most we cannot. Has anyone ever seen this for the admin user? I checked the user using 'isi auth user view admin' and the role using 'isi auth roles list -v --table-format' and compared those responses to our other cluster and they look the same. Does anyone have any other ideas or fixes??
Usually this happens because the software webui exists and doesn't lean up the pid file. (Which is localted at /usr/local/www/webkit/appserver.pid) and that just needs to be cleaned up so the appserver can restart.
I'm not sure if it has an auto restart feature or not, but it would be nice... but this doesn't happen to often so i'm not overly annoyed..
If you ran the following command "find -x /var -type f -size +1M -print0 | xargs -0 ls -lh " then you should have a list of files that you can prune out of your /var directory. your /var/crash directory looks pretty full as well and there is usually dump files and core files that can be removed there as well to help free up space. Just be sure you dont remove the following system directories out of /var/crash
/SupportIQ
/connectemc
/cto
But you can remove core files and old log files all you want. otherwise I would open a chat with support over this issue full system partitions can cause node reboots and impacted workflows if not resolved.
Hi, i started to delete old logs (i think) in /var/log, all files that end with .gz. i think they are old files. after that i have successful start of web service. if this is ok, i will continue with other files. i just need your confirmation that this is ok.
soetingr
1 Rookie
•
40 Posts
8257
0
Posted March 12th, 2013 03:00
This happened to us to. Please run the following on the node where you have the problem.
webui_webware_ctl restart
This resets the admin gui on a node.