Start a Conversation

This post is more than 5 years old


Go to Solution


March 19th, 2013 22:00

XPS 13 Ultrabook battery not charging

Hi My year old XPS 13 Ultrabook's battery is not charging when plugged in. I measured the voltage of the power adaptor at the plug (the end that connects to the Ultrabook) and the voltage level seem fine at 19.4V However when I plug and unplug the power when the Ultrabook is off, the LED turns on and off accordingly. My Ultrabook is L321x, running Windows 7, and has BIOS A7 installed. Does anyone have the same issue, and is there anything I can do to check what wrong? Thanks for any help Ka

1.5K Posts

March 19th, 2013 23:00

Hi kc.yyz,

I would suggest you to drain the residual power from the laptop:

  • Disconnect any external peripherals (flash drives, printers, external hard drives) from the computer
  • Then remove the adapter and the battery
  • Press and hold the power button for 10 seconds
  • Reconnect the battery and the adapter

Check the status of AC adapter in BIOS, follow the steps below:

  • Restart or turn on your computer
  • As soon as the Dell™ logo appears, tap until the message Entering Setup appears
  • ‘AC Adapter’ will be listed under the Main tab, and it should be 45 Watt

If the AC Adapter is determined in BIOS, you can update the system BIOS to A08. You may download and install the latest BIOS from the link below:

Also, you can check the battery health from the ‘Dell Battery Meter’. The Battery Meter is used to check the status, life and health of the battery. To launch the Battery Meter:

  • Click ‘Start’
  • Click ‘Control Panel’
  • Click ‘Power Options’ under ‘Hardware and Sound’
  • Click ‘Dell Battery Meter’

The battery status on this system can also be found using the LEDs, which are located on the right of the system. Press the button located near the LEDs to check the battery charge. Each glowing LED represents 20% of battery charge.

Hope this helps. Please reply if you have any other questions.

5 Posts

March 21st, 2013 22:00

Thanks, draining the battery and then power cycle did the trick. The ultrabook can now recognize the power adaptor and is charging. I was also able to upgrade to BIOS version A8.

March 26th, 2015 02:00

OK, people, me again.

So I changed EVERYTHING in that *** computer.

I started with the battery, then went to change the motherboard (upgraded to a superior model), this DID NOT change a thing.

Once you spent that much money to change that much, you wonder.

So you go on and change what's left: Adapter. Didn't change a thing. Adapter plug (inside the computer): didn't change a thing.

Went further. Unplugged the SSD and the wireless card. Just to check.


And finally, unscrewed the adaptor plug inside the computer. And "Voila". Don't ask, the BIOS now sees the adapter for what it is, the battery is charging.

Feels like a short circuit.

Whatever it is (if you have an idea... I'll hear it!), if you guys have the same problem... try unscrewing that stupid thing!

13 Posts

April 4th, 2015 01:00

Hi ... question:  was your plug loose before or was it nice and tight.

Mine is not charging, but adapter connector is whobbly and loose.   I've ordered a new $7 plug connector wire.   But I was surprised with yours worked right after you unscrewed the plug and and retightened it.

I'm hoping the same.

13 Posts

August 22nd, 2015 17:00


Sorry man, if the BIOS and adapter didn't work you have fallen into the DELL design of planned obsolesance and forcing you to purchase a new laptop.   Your motherboard's DC Charge circuit has *** out and is not repairable.  You actually need a new motherboard.  The repair cascade for  where you are is to NEXT:

       a) buy a new battery ($86)

       b) then when that fails, than replace the AC Charging Port Connector on the MB ($25)

       c) then replace the MB ($375)

So ... I suggest that you don't go down the additional $475 path on this piece of *** by DELL.   Check the forum and you will see a very very high incidence of this Product/Design Failure.   Must of the people had this occur within 6 months to 1 yrs of warranty expiration.  This happened to me TWICE, so I am feed up with DELL.  The 2nd time, I had purchased the extended warranty, and the same problem occurred with 6 months of the warranty expiration ... but how did they know?   Hmmm, leads to several product management designed conspiracy theories.   But I'll never buy any DELL.   ASUS is just so much better.

I'm a DELL XPS13 user and a father who purchased another DELL XPS13 for my college daughter, so my situation is true. 

PS:  If you want to try to take more repair steps, I have a NIB XPS13 battery and 2 XPS13 used laptops which you can use as parts.

Signed:   "I Hate Dell"   (

13 Posts

December 4th, 2015 09:00

I spent $1700 on this poor quality Laptop.

Then after the extended warranty expired by 1 month, spent another $475 in part repairing their battery, charger adapter, keyboard, etc .... I finally gave up on this money pit.

I will never purchase a DELL again.    The design is good, but the manufacturing quality is so poor ... you'll be spending more on maintaining the unit than your real work.

If you want to buy a Chinese laptop .... don't pay DELL for the privilidge.   Buy it from Asus and cut out the American middleman and save $$$$$$$.   Since Asus (Tiawan company) operations soeaj Chinese, I think they manage their outsourcers much better than DELL.   Asus products don't seem to fail in 2 yrs like the DELLs. 

1 Message

April 25th, 2016 10:00

That was the exact same issue I had. I took the adapter plug off and put a piece of black electrical tape on the bottom and screwed it back into the chassis and it fixed the issue. No more grounding out and it is now charging properly.

Here is a bit more detail. I took the bottom off the laptop using a T-6 torx driver, T-5 will work but be careful not to strip the screws. Once I had the bottom off I located the Power plug where the power cord plugs in. There is one screw holding it down. So I followed the lead to the motherboard and unplugged it, Then I carefully pulled the plug out of the computer enough to get to the underside of it. I then cut a piece of black electrical tape and taped it to the bottom of the plug and put everything back together. Apparently the internal plug was grounding out on the chassis. This fixed the issue for me.

1 Message

April 2nd, 2017 12:00

So my problem with my dell XPS 13 ultrabook not charging was in the charging port inside of the computer. It turned out that the port was at a slight angle breaking any connection between the power cable and the internal port. I eventually discovered this after being able to charge when I plugged in the cable at a very specific angle but otherwise got "Not Charging" from the battery, I'm not sure if this is from wear to the laptop or is a manufacturing defect. So I opened up my laptop and attempted to re screw in the port, this did not work. After many attempts I discovered a solution! I used plastic (A small piece of an old credit card) I drilled a hole the same size as the screw in it  to make a sort of nut that I placed where the screw screwed the internal charging port to the motherboard, This was the perfect size to level the port to where it needed to be! And just like that my laptop was charging perfectly every time! I hope this solution works for you!


1 Message

July 5th, 2017 02:00

I have been suffering the same issue.  I had to replace the power jack as the old one had broken inside. Since I did that, the laptop would not recognise the AC adapter and refused to charge.  I tried the power drain option and other suggestions but no joy until I tried unscrewing the adapter plug as mentioned above.  As soon as I did that it worked. I replaced the shiny silver screw with a black coated one and that has cured the problem.  Laptop now recognises the AC adapter and is charging as it should.

1.5K Posts

March 23rd, 2013 22:00

Hi kc.yyz,

I'm glad to know that the issue has been resolved. Please reply if you have any other questions.

4 Posts

May 10th, 2013 20:00

I'm having a similar issue.  XPS 13 (L321X).  Battery check says "8% available (plugged in, not charging)".  No degredation over time - just refusing to recognize charger.  Tried to update to the  latest BIOS but says I need >10% battery life.  Please advise.

4 Posts

May 10th, 2013 21:00

Additional info:  BIOS Version = "A06"; AC Adapter Type = "Unknown" (when plugged in, otherwise "None" when unplugged); Battery Health = "This battery is performing normally"

5 Posts

May 10th, 2013 23:00

sounds like the same issue i had. somehow draining the battery fixed mine as suggested by Amogh. After discharge and a power cycle, i was then able to charge and update bios.

it seems that the charging circuit is stuck, and maybe draining the battery (totally) causes it to reset.

so far i've not had this problem again - crossing my finger.

4 Posts

August 1st, 2013 19:00

Hey OccomPond did you had your problem solved? My XPS L321x is now on 0% of battery and it`s not possible to update the BIOS. There is anyway to bypass this battery check?

Current BIOS firmware is "A06" and I`m getting the same message on windows battery indicator: "Connected but not charging".

Any ideas on how to solve this?


August 1st, 2013 19:00

Hi rcmurad

I am sorry about this issue. Please follow these steps and reply with your findings.

1.     Check the AC adapter status in bios. (F2 during startup)

2.     Check the battery health meter for battery health. (Steps already mentioned in the same thread by Dell Amogh G)

3.     Check with a known good adapter if any.

No Events found!