Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

1558636

March 19th, 2013 22:00

XPS 13 Ultrabook battery not charging

Hi My year old XPS 13 Ultrabook's battery is not charging when plugged in. I measured the voltage of the power adaptor at the plug (the end that connects to the Ultrabook) and the voltage level seem fine at 19.4V However when I plug and unplug the power when the Ultrabook is off, the LED turns on and off accordingly. My Ultrabook is L321x, running Windows 7, and has BIOS A7 installed. Does anyone have the same issue, and is there anything I can do to check what wrong? Thanks for any help Ka

2 Posts

December 2nd, 2015 09:00

Had the same issue on my XPS 13 L321x: the computer would stop charging while plugged in. As others have said, apparently the charging port was causing a short. I did all of the power cycling suggested, and removed the charging port screw and put it back in. This helped temporarily, but as soon as the laptop was back together it stopped working again.

Ultimately what seems to have fixed it is this: I removed the charging port screw, wrapped the port itself in one layer of electrical tape, put tape on either side of the screw hole on the port, then *** it back in and put tape over the head of the screw. Now the connection is steady even if I push firmly on the plug in any direction, thank God -- I love this machine, and wasn't looking forward to buying another.

13 Posts

December 4th, 2015 09:00

Is it still working?   I think that I did that also, because I purchased a $7 replacement AC charger adapter plug and notice while screwing in/out the old plug ... that the changer power was going on/off.   I tried wiggling the screw and noticed some give.   But utiimately broke it while tightening it down to relieve the "give".  I also tried electrical tape to isolate the nearby metal bracket next to the screw ... but in the end everything failed.

Wishing you a permanent fix.    Mean has been replaced by Asus.

2 Posts

December 5th, 2015 07:00

Nope, you saw it coming . . . the connection is extremely shaky again. It only works when the adapter is plugged in just so; if you bump it the connection is lost. Rats! I want to make this thing work, since a) I don't want to buy a new computer, and b) I really like everything else about this one. Does anyone know of a permanent fix? Duct tape, maybe? (c: It seems like it ought to be an easy fix!

1 Message

January 13th, 2016 12:00

I also have a "premium XPS 13 Laptop" that wouldn't charge after about 1.5 years.  By 2 years it wouldn't turn on at all even plugged in, and Dell charged me around $300 to repair the issue and 9 months later the same issue popped up.  Customer support wants me to pay them more to repair it again, and it would be really dumb to take them up on this.  This ultrabook touted as a premium product is defective in my opinion, and I have filled consumer complaints with the California Attorney Generals office and the FTC.  This is nearly the exact same issue Apple was forced to settle a class action 2 years ago, and I expect there will be a new recourse for consumers like me who were ripped off.  This is the last dollar I will ever spend with Dell both personally and for the businesses I run.

10 Posts

April 12th, 2016 19:00

This happened to me as well. I've had my computer less than one year so it's still under warranty. After reading this forum and doing everything suggested, I called tech support and they are sending someone out to replace the motherboard.  Annoying.  Of course they repeated everything I already did, insisting they could fix it, first. 

10 Posts

April 18th, 2016 10:00

I had to get my motherboard replace to fix this issue.

1 Message

August 17th, 2017 01:00

I can concur that after having replaced the power jack and AC adapter, the adapter wasn't recognised anymore and insulating the jack from anything metal in the case, including the screw touching the jack resolved my problem! Please, try this before replacing the motherboard!!

September 30th, 2017 09:00

Same problem. Scoured countless fourams and tried cha ging the dc jack, bought a new dell charger but still same issue.  Finally took the screw out of the dc jack. Charged straight away. I insulated the screw, screw hole and the edge of the dc jack port so would not come into contact with the screw and now charges every time. My conclusion - bad earth. Took me 10 mins s to fix.

Come on DELL. THIS IS A COMMON ISSUE. FIT THE DC JACK WITH A COMPLETE NYLON SCREW AND SAVE US LOYAL CUSTOMERS A LOT OF WASTED TIME AND MONEY.

No Events found!

Top