Start a Conversation

Unsolved

J

1 Message

1359

February 9th, 2023 06:00

Dell Enterprise Storage Analytics for vROPS version 7.1 fails to upgrade

Hi, 

I have recently upgraded my vROPS from version 8.6.2 to version 8.10.2 but I am getting errors when trying to update the Dell ESA Management Pack from version 6.3.1 to version 7.1 (even 7.0 is failing). For some reason the upgrade fails with the following error right after I click upload:

"PAK Manager: PAK file /storage/db/casa/pak/dist_pak_files/cargo/reservedTemp_6613844667015435493.pak is not in zip format"

Any details on how to fix this issue would be appreciated. Thank you in advance

Moderator

 • 

3.4K Posts

February 9th, 2023 11:00

Hello Javier_Rod,

 

Try renaming the .pak to .zip

 

I see this note in the Dell Enterprise Storage Analytics for vRealize Operations 7.0 Product Guide

https://dell.to/3DVArKo

Page 13

NOTE: If You use Internet Explorer, the installation file downloads as a ZIP file but functions the same way as the PAK file.

 

That tells me that it can use either .pak or .zip

I downloaded DellEMCEnterpriseStorageAnalytics-7.1.0-build-2308_signed.pak then changed extension to .zip and it extracted fine.

Moderator

 • 

3.4K Posts

March 6th, 2023 07:00

Hello bkin,

 

The recommendation was to rename to .zip and supply the .zip file, not to extract the .zip files.

 

Can you provide the page you are using that the checksum does not match for me to look into?

14 Posts

March 6th, 2023 07:00

I have the same issue.
While you can 'change the extension to zip and extract it', this is not the procedure for installation and does not solve the original question.  While you may be able to extract the zip file, 'zip' is not an accepted file format for vROPs, and the pak file fails to upload.

I will also note that the file does NOT match the checksum values, after downloading from multiple browsers / locations, therefore I suspect the issue is with the file currently being hosted.

9 Posts

April 11th, 2023 17:00

I have the same issue.  7.0 & 7.1 ESA PAK files show "archive corrupted" when opening with a zip utility.  Version 6.3.1 opens without error.  I've tried Chrome, Firefox, and IE browsers.  All show corrupt packages after downloading.

E:\Downloads\DellEMCEnterpriseStorageAnalytics-7.1.0-build-2308_signed.zip: Unexpected end of archive

I found this article for v7.0 - matches the issue exactly.  Just says to download and compare checksum.  I've done this - they don't match.  I've tried downloading multiple times, multiple systems, multiple browsers for over a week.  

www.dell.com/support/kbdoc/en-us/000204311

This is the hash shown in "checksum values" link next to the download
 
File Name
DellEMCEnterpriseStorageAnalytics-7.1.0-build-2308_signed.pak
SHA-256
2447efa8907d48b94938c2be6b3d357dd614eef8db3088c81e47a7712bf84ce4
 

PS E:\Downloads> Get-FileHash E:\Downloads\DellEMCEnterpriseStorageAnalytics-7.1.0-build-2308_signed.pak -Algorithm SHA256

Algorithm Hash Path
--------- ---- ----
SHA256 0BA12C213B0A20BC0452AEDE59FD3DA43C0E5EACC969500DBDEC2A01B5324728 E:\Downloads\DellEMCEnterpris...

The hashes don't match.  7.0 and 7.1 versions are affected.  6.3.1 and prior downloads pass hash check and zip check.  If you rename the file extension to ZIP, then vROPs will refuse to upload it (error states it must be a PAK file).

 

Moderator

 • 

3.7K Posts

April 11th, 2023 23:00

Hello, thanks for choosing Dell.

We downloaded the file, tested checksum and it matches. Could you maybe try on another network? outside of your company?

1 Attachment

9 Posts

April 12th, 2023 11:00

Having the same problem here.  vROps does not like the downloaded pak file and attempting to view/extract it (either as a PAK or ZIP) using 7zip gives the unexpected end of archive message.  6x pak files unzip with 7zip just fine.

9 Posts

April 12th, 2023 11:00

I downloaded the same file at home, on a personal Mac (previous attempts were using Windows on a corporate network with restrictions).  Same issue - PAK (zip) is corrupt, and SHA256 hash doesn't match.  If I download v6.3.1 of ESA, the file is complete, hash matches, and I am able to install in vROPs.  v7.0 and v7.1 both fail downloading from EMC on any platform or network.

9 Posts

April 14th, 2023 10:00

Not sure if this will help others or not but I was able to reach out to my DellEMC SE and he downloaded it internally and got it to me.  There's definitely something busted with the file as it's provided from the tinyurl generated on the downloads page.  So my suggestion to folks for now is reach out to your rep to have them help get you the file.

9 Posts

April 14th, 2023 13:00

Is it possible for you to post the good copy you were able to download?  The copy provided from the site to us is still broken.

4 Posts

April 15th, 2023 05:00

Hello Amber,

It seems like you are encountering an issue when upgrading the Dell ESA Management Pack in vROPS 8.10.2. The error message you are receiving indicates that the PAK file you are trying to upload is not in the expected zip format.

Here are a few steps you can take to troubleshoot this issue:

  1. Check the PAK file: Ensure that the PAK file you are trying to upload is not corrupted or incomplete. You can try re-downloading the file or obtaining it from a different source.

  2. Check file permissions: Verify that the account you are using to upload the PAK file has the correct permissions to access the file and the required directories on the vROPS server.

  3. Check vROPS disk space: Ensure that there is enough disk space available on the vROPS server to store the uploaded PAK file. You can check this by logging in to the vROPS console and navigating to Administration > System Status > System Health.

  4. Check vROPS logs: Review the vROPS logs to see if there are any additional error messages or details that can help diagnose the issue. The logs can be accessed via the vROPS console under Administration > Support > Logs.

If none of the above steps resolve the issue, you can try reaching out to the Dell support team for further assistance. They may be able to provide additional troubleshooting steps or insights on this issue.

I hope this helps!

[Best Regards]

Olivia Devid

9 Posts

April 17th, 2023 08:00

Please re-read the thread.  The issue is with the file from EMC, even before vROPS is relevant.  The 7.x ESA PAK files from EMC are corrupt on download, chechsums don't match.  6.x files are fine.  This has been confirmed by EMC Support, as they are able to download internally and the checksum is fine.  Confirmed by multiple users that downloading externally is NOT working.  Test from outside EMC, and you'll see the same.  Please fix the 7.x ESA for vROPs downloads.

9 Posts

April 24th, 2023 09:00

Any word on this issue - a week later and both 7.x downloads for ESA are still broken (archives corrupted) no matter how I download.  The 6.x ESA files are fine.  Please fix!

Moderator

 • 

8.5K Posts

April 24th, 2023 10:00


I am not seeing anything released on it yet, but we also only have access to limited details on releases and their release times.

9 Posts

May 3rd, 2023 16:00

These downloads have been broken for months now.  Can we get a commitment from Dell / EMC that these files will be fixed and made available soon?  What's the point of reporting this to the community team if nothing is ever done about it.  I guess I'll have to get my sales and support teams involved for what should be a simple fix from EMC.

1 Message

May 5th, 2023 09:00

Having same issue too, now on Aria 8.12, have tried every version available all with same issue

No Events found!

Top