Start a Conversation

Unsolved

V

8 Posts

23

October 18th, 2023 07:59

RAID controller stalls when running perccli64 commands

Hello Dell community,

BIOS version: 2.17.0

RAID firmware: 25.5.9.0001

We have a Dell PowerEdge R730xd with PERC H730P Mini RAID controller.
On this server we have CentOS 7 installed running on the laterst kernel and software updates.

When we run the command 'perccli64 /c0 show' the RAID controller stalls for some seconds and all discs lock up.

Here is an output of the RAID controller termlog when the 'perccli64 /c0 show' command has been ran:

10/15/23 19:27:18: C0:process_dcdb_callback: No valid issuer Sense address for the sense Data sdAddr:25ff68c sdLen:0 cmdId:2410/15/23 19:27:18: C0:cmdId= 24: cmd=3, cmdStat=0, num_sg_elements=1, status=1 [PCI_COMMAND], chainFrameAllocated=110/15/23 19:27:18: C0:mfa=94400, mf=416bd000, mfSge=416bd030, bytesTransferred=0, next ffff10/15/23 19:27:18: C0:lmid=2ab smid=39b ioCmplType=2 iotype=0 LockGranted=0 lockType=0 isRunOnSecondary 010/15/23 19:27:18: C0:startTime=12cecd7, waitTime=0 lines=447d25a0, lineMap=0, activeRecoveryCount=0, lockPromotedByRec=010/15/23 19:27:18: C0:ldbbmAlreadyTried=0, ldbbmIssueWriteAsWV=0, recoveryAttempted 0 bypassIo 010/15/23 19:27:18: C0:SGLIsIEEE=1, dontGroupFurther=0, isParentOfSplitCmd=0, isChildOfSplitCmd=010/15/23 19:27:18: C0:hdr.length=20 hdr.targetId=4 rsLen=0 flags=c02dbb70, msg=40cb2e0010/15/23 19:27:18: C0:CDB: 4d 00 4d 00 00 00 00 00 20 0010/15/23 19:27:18: C0:CMD_PCI: cmd=03, cmdId=24, nsg=1, pd=04, timeout=1e, cdb= 4d 00 4d 00 00 00 00 00 20 0010/15/23 19:27:18: C0:process_dcdb_callback: No valid issuer Sense address for the sense Data sdAddr:24eb68c sdLen:0 cmdId:2410/15/23 19:27:18: C0:cmdId= 24: cmd=3, cmdStat=0, num_sg_elements=1, status=1 [PCI_COMMAND], chainFrameAllocated=110/15/23 19:27:18: C0:mfa=94000, mf=41750000, mfSge=41750030, bytesTransferred=0, next ffff10/15/23 19:27:18: C0:lmid=304 smid=397 ioCmplType=2 iotype=0 LockGranted=0 lockType=0 isRunOnSecondary 010/15/23 19:27:18: C0:startTime=12cecd7, waitTime=0 lines=447d25a0, lineMap=0, activeRecoveryCount=0, lockPromotedByRec=010/15/23 19:27:18: C0:ldbbmAlreadyTried=0, ldbbmIssueWriteAsWV=0, recoveryAttempted 0 bypassIo 010/15/23 19:27:18: C0:SGLIsIEEE=1, dontGroupFurther=0, isParentOfSplitCmd=0, isChildOfSplitCmd=010/15/23 19:27:18: C0:hdr.length=20 hdr.targetId=6 rsLen=0 flags=c02dbb70, msg=40dd4c0010/15/23 19:27:18: C0:CDB: 4d 00 4d 00 00 00 00 00 20 0010/15/23 19:27:18: C0:CMD_PCI: cmd=03, cmdId=24, nsg=1, pd=06, timeout=1e, cdb= 4d 00 4d 00 00 00 00 00 20 00

Anyone an idea what is going wrong?

Moderator

 • 

8.3K Posts

October 18th, 2023 12:35

Vlegel,
 
I haven't seen this issue before, so I would start with verifying the entire server is up to date, as well as that you are using the latest supported version of the perccli utility. Would you also confirm if you see the same issue or an error, when you use the command perccli /c0 show?
 
Lastly, and although rare, I would ensure that the controller index is indeed 0.
 
Let me know what you see. 
 

8 Posts

October 19th, 2023 06:56

Hi Chris,

Thank you for your reply!

When we run perccli64 /c0 show it shows:

"Generating detailed summary of the adapter, it may take a while to complete."

After a few seconds we receive the RAID information output, but when executing the command all disks stall.

The controller index is indeed 0


The perccli software is up-to-date, also all other CentOS packages, kernel etc. are up to date.

(edited)

Moderator

 • 

3.1K Posts

19-10-2023 01:50 PM

Hi,

what about Firmware and UEFI?

 

 

8 Posts

October 23rd, 2023 08:11

@Dell-Martin S​ 

BIOS version: 2.17.0

RAID firmware: 25.5.9.0001

Moderator

 • 

3.1K Posts

23-10-2023 02:42 PM

thx

No Events found!

Top