I have a cluster of 2 server, OS is RHEL 5.3 kernel version 2.6.18-128.el5, both installed with PowerPath 5.3 and each server using 2 HBA.
We do a testing of path failover, when I unplugged 1 FC cable from 1 of the HBA, the cluster will failover. I believe the proper behaviour is that only the path that is being failover which is handled by PowerPath.
Can anyone help me with the issue, is there any configuration that I should do on the PowerPath side? Thanks in advance.
what cluster s/w? Red hat cluster Suite( which version) with Quorum disk?
what you have in /etc/modprobe.conf? We have the following entry which disables the fail over at HBA level rather PP/Array handles fail over. ( that is what i remember about this entry)
Yes its a redhat cluster suite with a quorum disk. I'm not sure what version is installed, how can i check that?
I have read some articles about the /etc/modprobe.conf options, but when i add those lines, i get error messages whenever i do a modprobe. Some said have to do mkinitrd after i add the options, but whenever i do mkinitrd, it saying that there is no changes on the kernel...
[root@SERVER1 ~]# cat /etc/modprobe.conf alias eth0 e1000e alias eth1 e1000e alias eth2 bnx2 alias eth3 bnx2 alias scsi_hostadapter mptbase alias scsi_hostadapter1 mptsas alias scsi_hostadapter2 ata_piix alias scsi_hostadapter3 qla2xxx alias bond0 bonding options qla2xxx ql2xfailover=0 ConfigRequired=0 # options bond0 mode=balance-alb miinom=100 ###BEGINPP include /etc/modprobe.conf.pp ###ENDPP
Yes i use the -f options when running the mkinitrd command, i forgot the exact error message. when i can down the cluster, i'll try to do it again and post the result.
Please find as below when i change the /etc/modprobe.conf and then do mkinitrd. I got message for 'No modules available for kernel "initrd-2.6.18-128.el5"'
[root@SERVER1 boot]# cat /etc/modprobe.conf alias eth0 e1000e alias eth1 e1000e alias eth2 bnx2 alias eth3 bnx2 alias scsi_hostadapter mptbase alias scsi_hostadapter1 mptsas alias scsi_hostadapter2 ata_piix alias scsi_hostadapter3 qla2xxx alias bond0 bonding options qla2xxx ql2xfailover=0 ConfigRequired=0 ###BEGINPP include /etc/modprobe.conf.pp ###ENDPP
[root@SERVER1 boot]# ll total 12474 -rw-r--r-- 1 root root 64994 Dec 17 2008 config-2.6.18-128.el5 drwxr-xr-x 2 root root 1024 Aug 14 10:49 grub -rw------- 1 root root 3230851 Aug 14 10:16 initrd-2.6.18-128.el5.img -rw------- 1 root root 3230851 Sep 20 11:13 initrd-2.6.18-128.el5.img.backup -rw-r--r-- 1 root root 2982241 Aug 15 02:57 initrd-2.6.18-128.el5kdump.img drwx------ 2 root root 12288 Aug 14 10:11 lost+found -rw-r--r-- 1 root root 102182 Dec 17 2008 symvers-2.6.18-128.el5.gz -rw-r--r-- 1 root root 1188481 Dec 17 2008 System.map-2.6.18-128.el5 -rw-r--r-- 1 root root 1889308 Dec 17 2008 vmlinuz-2.6.18-128.el5
[root@SERVER1 boot]# mkinitrd -f initrd-2.6.18-128.el5.img initrd-2.6.18-1 28.el5 No modules available for kernel "initrd-2.6.18-128.el5".
[root@SERVER1 boot]# ll total 12474 -rw-r--r-- 1 root root 64994 Dec 17 2008 config-2.6.18-128.el5 drwxr-xr-x 2 root root 1024 Aug 14 10:49 grub -rw------- 1 root root 3230851 Aug 14 10:16 initrd-2.6.18-128.el5.img -rw------- 1 root root 3230851 Sep 20 11:13 initrd-2.6.18-128.el5.img.backup -rw-r--r-- 1 root root 2982241 Aug 15 02:57 initrd-2.6.18-128.el5kdump.img drwx------ 2 root root 12288 Aug 14 10:11 lost+found -rw-r--r-- 1 root root 102182 Dec 17 2008 symvers-2.6.18-128.el5.gz -rw-r--r-- 1 root root 1188481 Dec 17 2008 System.map-2.6.18-128.el5 -rw-r--r-- 1 root root 1889308 Dec 17 2008 vmlinuz-2.6.18-128.el5
dynamox
11 Legend
•
20419 Posts
•
87439 Points
530
0
Posted September 20th, 2009 15:00
Is PowerPath licensed ? What array is this system connected to ? If it's clariion..what failover mode is set to ?