Start a Conversation

Unsolved

J

1 Rookie

 • 

1 Message

177

February 29th, 2024 20:48

Cannot Install SA 4.0.1.54588

When I opened SA (v4.0.0.51819) this morning, a message appeared to tell me an update was available. I went through the process to update SA to v4.0.1.54588. After a few minutes, this message appears: "We ran into a problem. Restart your PC, then try again." Error code: 1603 appears in the bottom right of window. According to the web page that opens when I click on the error code, a fatal error occurred during installation. The possible recovery options state to restart my computer and try to install again. When I did this, the update failed again (surprise!) with the same error code 1603. I've tried this several times, all with the same result.

I should also note that since I installed SA v4.0.0.51819, I have not been able to sign in to SA with my Dell.com credentials. This has been widely reported in previous posts. Fortunately, I am still able to run the various SA tasks.

5 Practitioner

 • 

2.4K Posts

March 3rd, 2024 16:20

Error code 1603 is because Dell Client management service fails to install/Start 

Removed SupportAssist and Dell Update (if installed) using this windows fixit Fix problems that block programs from being installed or removed - Microsoft Support (important don't uninstall from program and features, use this fixit only. 

Uninstall any dotnet version 6.0 or higher from program and features.

Delete key registry keys from HKLM\SOFTWARE\dotnet\Setup\InstalledVersions\x64\sharedhost

Reboot 

Reinstall Fix problems that block programs from being installed or removed - Microsoft Support (dell.com)

Warning - My experience with SupportAssist 4.x is very bad, I removed and reinstalled it and got version 3.14 instead so it seems like Dell has pulled it back

No Events found!

Top