Start a Conversation

Solved!

Go to Solution

2115

May 31st, 2022 07:00

WMS Upgrade from 3.6.1 to 3.7 failed

Hello,

I tried to upgrade my WMS Server from 3.6.1 to 3.7.

I received an error message during the Upgrade Database step.

on the migration.log file i can see that:

"31/05/2022 15:22:44,49 Start migration script 4.7.6-4.7.7"
"31/05/2022 15:22:44,50 Arguments set"
"31/05/2022 15:22:44,51 WMS Database Upgrade Process started "
"31/05/2022 15:22:44,62 Current schema version is 4.7.6"
"31/05/2022 15:22:44,62 Upgrading schema to 4.7.7 version"
"31/05/2022 15:22:44,63 mysql -ustratus -p*** -hlocalhost -P3306 stratus < stratus-migration-4.7.6-4.7.7.sql"
"31/05/2022 15:22:44,93 WMS Database schema upgrade process failed. Restore the db and upgrade again "

i think that i found the lock because when i tried manually i received this error:

C:\>"C:\Program Files\DELL\WMS\MariaDB\bin\mysql.exe" -ustratus -p****** -hlocalhost -P3306 stratus < stratus-migration-4.7.6-4.7.7.sql

ERROR 1062 (23000) at line 12: Duplicate entry '8' for key 'UK_sye0l11aem2xlx253kgf2yyob'

thanks for any help

June 7th, 2022 05:00

This is the answer from Dell support that solved my issue to upgrade my 3.6.1 to 3.7.

MySQL Upgrade steps:

  • Stop “Dell WMS: MariaDB” service.
  • Download MariaDB Binary from location: https://archive.mariadb.org/mariadb-10.6.5/winx64-packages/mariadb-10.6.5-winx64.zip
  • Copy New MariaDB-10.6.5 Binaries to C:\Program Files\DELL\WMS\MariaDB folder.
  • Rename the SQL log file - C:\Program Files\DELL\WMS\Database\SQL\ib_logfile0 to “ib_logfile0.old”
  • Rename the SQL log file - C:\Program Files\DELL\WMS\Database\SQL\ib_logfile1 to “ib_logfile1.old” (if exisiting)
  • Start “Dell WMS: MariaDB” service.
  • Run below command for MySQL Table migration.

Run by CMD :

C:\Program Files\DELL\WMS\MariaDB\bin\ mysql_upgrade -ustratus  -p -P3306 --debug-check --debug-info
 

  • Check for “C:\Program Files\DELL\WMS\Database\SQL\mysql_upgrade_info the file creation after running the above command successfully.

launch again the WMS_3.7.exe setup and enjoy.


= Your password provided during 1st installation on the wizard for MongoDB and MariaDB database

May 31st, 2022 07:00

i found that on the sql script:


####
##
## Start Schema Change from DB-4.7.6 (WMS 3.6) to 4.7.7 (WMS 3.7)
##
####
use stratus;

UPDATE DatabaseSchemaVersion SET UpdatedAt = Now(),VersionNo = '4.7.7' WHERE ID = 1;

## new license catagory itroduced : perpetual ThinOS Activation License
INSERT INTO LicenseCategory (CreatedAt, IsActive, UpdatedAt, Category, Description, Type, version) VALUES ( Now(),true,Now(), 'ThinOS Activation', 'ThinOS Activation', '8', '0');

## Activate ThinOS Activation License
INSERT INTO DeviceAction (CreatedAt, IsActive, UpdatedAt, Description, Name, Type, IsAutoSuccess, Priority, RegistrationPriority) VALUES (now(),1,now(),'Enable ThinOS Activation License','EnableThinOSActivation',100,0,20,100);

Line 12 is "INSERT INTO LicenseCategory"...

1 Rookie

 • 

681 Posts

June 1st, 2022 06:00

Did you restore a snapshot and try again?

Based on the query it looks like it is complaining about the values already existing.  If you query it prior to trying the upgrade how does that table/row look?

If this Is WMS pro, I would encourage you to open a support case for engineering feedback.

June 1st, 2022 06:00

Hi buffalobound,

Thanks for your reply.

Yes of course, i have snapshot and i reverse any time i tried something.

So i'm still in 3.6.1 before each upgrade.

for the query i don't know what i need to enter on the Cli.

Yes we have WMS Pro. But the support...i'm still pending since 2 months an answer about 1 subject about WMS Remote Repo issue.

No Events found!

Top