Start a Conversation

Solved!

Go to Solution

47

February 19th, 2024 15:04

E2600 onboard ethernet, possible trouble

I am having trouble accessing certain websites or parts of websites when my PC is connected with a CAT5 cable.  I get intermittent "connection reset" errors, "bad record mac alert" errors, and "http2 protocol" errors even with different web browsers.  This particularly happens with login pages.  These errors do not occur with a wireless connection to the computer or with other devices connected to my WiFi.  There are no hardware errors when I use Dell's SupportAssist.  I've tried different CAT5 cables, cleared browser caches, and gone through extensive troubleshooting with my ISP.  I understand the E2600 cannot be replaced without replacing the whole motherboard.  I'd rather use a wired connection rather than WiFi, so is there anything else I can try?    

10 Elder

 • 

43.5K Posts

February 19th, 2024 19:39

Are these Ethernet cables CAT5 or CAT5e?  How long are they?  If they're all CAT5, you may want to upgrade to CAT5e or CAT6.

Have you tried rebooting the router/modem?

You didn't tell us the PC model or version of Windows, but is the latest Killer Ethernet driver installed from Dell's support site for your PC model and version of Windows?

You could also try clicking Start>Run>services.msc. When services.msc opens find all Killer services (and xTend services, if any) and change each one's Startup type to disabled. Then reboot PC and see if this helps.

Community Manager

 • 

54.2K Posts

February 19th, 2024 16:29

To receive assistance from Dell support agents they need to first verify the ownership and warranty status. Click the blue "Get Help Now" on the right to start a private live chat session. Share the private PC service tag with them.

Before our users can assist, they need more data =
* What specific PC model?
* What operating system?

(edited)

3 Posts

February 19th, 2024 21:01

@RoHe​ The pc is XPS 8940 running Windows 11.  It is a cat5e cable, and it's about 5-6 feet long.  The modem was rebooted several times and troubleshooted by Xfinity with no luck.  I have the latest Ethernet driver installed as well.  I will try your suggestion re: services.msc. Thanks!

(edited)

10 Elder

 • 

43.5K Posts

February 20th, 2024 20:47

Are these decent quality CAT5e cables, not cheapies?  

Do you know if Xfinity checked/adjusted the MTU settings for your router?

Killer software (services) can contributes to errors like "bad record mac alert", especially with with Chrome.  So disable all Killer (and xTend) services. reboot and see if that solves the problem.

Also be sure to clear cache, cookies, history for whichever browser(s) you use. And if you have any add-ons installed in a browser(s), disable all of them too.  If disabling add-ons helps, you could re-enable them one at a time to see if you can ID the troublemaker...

Also, what anti-virus software do you use?

Open the PC's clock in notification area of taskbar. Make sure it has correct date/time for your location.  Also make sure it's set to update itself automatically, and then click the option to sync immediately.

3 Posts

February 21st, 2024 00:42

@RoHe​ Thanks - disabling the Killer services in services.msc and rebooting solved the problem completely.  I did not have to tinker with anything else. 

10 Elder

 • 

43.5K Posts

February 21st, 2024 01:06

Yea!  Simple fixes are always the best...

I just don't understand Intel continually releases bad software (they own Killer)...

Lesson I learned over the last couple of years is whenever Killer Ethernet in my PC acts up (low up/download speeds, errors, etc) is to check in services.msc to make sure those Killer (and xTend) services didn't get re-enabled by an Intel update installed by Windows Update when I wasn't looking...

No Events found!

Top