Start a Conversation

Solved!

Go to Solution

1 Rookie

 • 

25 Posts

5831

April 15th, 2023 20:00

isHighlyActiveTopic

XPS 9520, audio quality decreases

I have a 9520 and it is my third replacement unit. All units have had the same issue. If I am using a voce chat app like discord or zoom and try to play a game or play audio on any application like youtube, the audio quality decreases significantly like its coming through an old school radio. If I am using a head set and try to do the same thing mentioned above, the voice chat app will stop detecting my input and output until I reselect the input and output and in some cases this doesnt work either. as soon as i go back to the other application it stops detecting the input and output once again. This happens with any audio device I connect to the computer. I have gone through every possible resolution with the support assist people, but had no luck, they have replaced the laptop 3 times and every unit has the same problem. This makes me think it is software, but I have done a clean install of windows and uninstalled waves maxx audio pro and still the issue persists. All of my external devices have been tested on separate computers and work perfectly, I have also reproduced the issue with every audio device i plug in as well as the built in speakers/microphone. I really need a solution to this as it significantly impacts the useability of this product and I cannot afford to call this a loss and switch to mac as I have already spent the money here and it is not refundable. Please help.

Community Manager

 • 

2.2K Posts

June 28th, 2023 07:00

A replacement system was sent on 06/26 to @TStien .

For the other users: if you're still having issues with your laptop, please start a chat using Get Help Now on the bottom right side of the page to talk to a support agent. Please be patient and run all the tests the agent will ask you to.

1 Rookie

 • 

13 Posts

September 19th, 2023 01:20

@Dell-Brad L​ 

I am able to fix the issues (Audio Distortion / Audio Drop) with my steps. 

Just sharing here and see if anyone also can fix the issues with steps. 

8 Wizard

 • 

17K Posts

April 15th, 2023 21:00

Not that is effects your issue much, but I wonder if your XPS-15_9520 also has the Nvidia-card or just the on-board Intel video.

I suggest you try a USB-based headset. This will have it's own "sound card" and drivers (the on-board audio-device and Waves-Maxx DSP nonsense will not even be used).

If you need some purchasing suggestions, just let me know. Mention if you want gaming headset (like Logitech) of more business-like like Plantronics. Post my name in thread so I will be notified.

3 Apprentice

 • 

4.3K Posts

April 16th, 2023 05:00

I don't have much experience with chat type applications, but maybe a couple of things to visit.  I, cannot verify what you are attempting, is even workable.  I am not on a Dell system right now but I will check and get back if I notice anything with such an operation.

You are saying just one process at a time, Zoom or YouTube, works fine?  It is only when you run a second, similar process that problems occur?

Have you tried lowering the audio quality?

Does it make any difference whether the system is plugged in or not?

My first thought would be to check the settings in the attachment.  You can get there by using mmsys.cpl in a run box.  Perhaps, if apps were allowed to share the devices, they would not disconnect when another one was used.

Have you verified, since all of this is online, that your internet connection is adequate?  If your system was seeing deficiencies during these sessions, it might try to make corrections to the current configuration.

I think you have proven the problem is not based on your computer.  

 

Saltgrass_0-1681649034866.png

 

 

 

1 Rookie

 • 

25 Posts

April 16th, 2023 07:00

discord and zoom are two of the most popular voice chat applications and discord specifically is designed to be used while streaming or gaming with friends (tandem applications with sound running at the same time). My XPS 7590 never had any issues doing any of this and I had 3 of them, which all were able to do this simple task. I am currently using a 6 year old microsoft surface pro 4 in place of my brand new xps 9520, which is able to do this task. This is a normal function of a computer and for "the best windows laptop" to not be able to do voice calls while doing other computer tasks is wildly frustrating. It is reproducible when running a voice chat app like zoom or discord while also having audio playing through another app like youtube or a video game (simple bread and butter stuff like communicating with a friend during a game like "Among Us").

Changing the audio quality doesnt seem to alter the issue.

The problem happens when plugged in or on battery power indiscriminately.

I have gone through the process of contacting the applications support team and done hours of tinkering in the applications setting and windows settings and no change has come from it. I have reinstalled windows 9 times. 

I have the fastest internet you can buy in a major city with fiber optic run straight to my house and the problem persists when on a wired connection through my dell docking station and when on wifi. It does not happen on other devices like the before mentioned surface or older xps 7590.

I dont understand how this product is selling like this. I have had 3 and they all have the same problem. its causing me to miss lectures, not be able to join in on discussions for group assignments and I cant play games with my friends. I should have got a Macbook.

1 Rookie

 • 

25 Posts

April 16th, 2023 07:00

My units have all had the rtx 3050 GPU. I have a wireless steelseries arctis 7 with a USB receiver, which i have tried with and without its own software. The problem is reproducible with every audio device i have looked up. I will try again with devices through the audio jack and fully usb wired connections, but this has already been tested and failed. Thank you for your suggestion.

1 Rookie

 • 

25 Posts

April 16th, 2023 08:00

This is how I reproduce the issue: 

- Open youtube shorts (shorts allows you to easily switch to a new video by pressing the down arrow, which initiates the problem).

- Open a zoom meeting

- At this time both youtube and zoom are using the same input and output. Be attentive to the sound quality of the youtube video. It will have likely changed. If it hasn't then go to the next video and then go back to the previous video (becasue you know what the previous video is supposed to sound like). At this point Zoom usually shows a pop up saying it cannot detect my microphone or speakers. This is easily resolved by just clicking test my device, which seems to turn the device back to zoom, (very annoying and not working properly). Now with the youtube shorts video still playing, end your zoom call and listen to the quality all of a sudden come back to your headphones. This is reproducible every time with multiple different headphones. it seems like the routing of the signal is not able to handle two applications or something which is just unheard of, let alone on a $2500 computer. like I said my $1000 computer from over 6 years ago handles this just fine and so did the XPS 7590 before this.

I also tried disabling exclusive mode and it changed nothing (I was really banking on it working).

8 Wizard

 • 

17K Posts

April 16th, 2023 10:00

Actually, I have the XPS-15_9520. Runs fine for me.

Be sure you are running the latest BIOS/Firmware (and all the sub-components also got updated ... like Thunderbolt ports).

You said you reloaded Windows-11. Was that Dell's version or Microsoft's? If Dell's, try uninstalling Support-Assist and some of the other heavy Dell driver-suites and Apps. Or, just install Microsoft's and use only drivers from Windows-Update (no Dell Drivers or Apps).

Be sure AC-Adapter is plugged-in and running in High Performance mode. Be sure all settings in Power Profile are maxed-out and all the limiting-stuff is disabled.

Discord should be fine, but there are some settings within.

Zoom is known not to play nice with other apps and barely functions on some hardware. If you are using it from a browser, try the native Windows App.

Your problem might be your Browser, or it's settings. If using Edge, try Chrome.

Be sure Nvidia card is configured to always run Apps (especially the games) in High-Performance mode.

Your problem might be your USB-Adapter/Hub. Try connecting charger and simple wired-USB Headset to laptop directly. Use one of these if you must.

If you are using Bluetooth (2.4ghz), be sure your WiFi Access-Point is instead the 5Ghz one.

Yes, put the fancy wireless SteelSeries Arctis 7 aside and test with something like this. I'm wondering if it's wireless radio is conflicting with your WiFi or maybe it's drivers are not quite-right (to allow concurrent apps operation).

If you want a MacBook, then I suggest you get one. Get a really nice/loaded one. The Mac-Studio (with M1-Max) is also nice if it doesn't need to be a laptop (sounds like you have plenty of those). However, remember that you can't get them with Nvidia card (for gaming) and you can no longer BootCamp them (so you will be limited to games and Apps that run natively on macOS).

 

 

 

1 Rookie

 • 

25 Posts

April 16th, 2023 11:00

I am glad yours works as this means there is hope for me. However, I have had 3 9520's all with the same problem and none of my other computers have this problem including my 2019 xps 15 7590. 

- Bios is up to date and this has been verified by Dells support assist team multiple times, along with attempting to update drivers for ever component imaginable.

- I have reinstalled windows 9 times total across 3 9520's. One of those times was a microsoft version on a new drive to eliminate the partition. I find it hard to only use windows drivers as the support assist app is handy for keeping my computer up to date, but if it is the only solution I will do it until I can afford a macbook... Given that I didnt have any luck with the microsoft version of the windows install, I am not overly confident that it will solve the issue, but worth another try at this point.

- AC is usually plugged in when issue occurs but not always (regardless, a laptop that cannot be used without being plugged in defeats the purpose of a laptops, doesnt it). I am confident this is not contributing to the issue though becasue it happens when plugged in. I have tried with power manager set to the highest mode. no change.

- I have had lengthy conversations with Discord support and tried all of their suggestions to no avail.

- I tried Zoom to help rule out discord as being the only app that causes the problem as the issue was originally noticed when trying to game when on discord. Zoom is just easiest to view and explain a reproduction of the issue.

- I am using Chrome and all apps are the desktop version. the browser doesnt seem to be the issue since this same problem happens when gaming which doesnt use the browser.

- I have the RTX 3050 set to run all relevant processes

- I have used 3 different usb hubs and all 3 USB-C ports on the laptop and reproduced the issue indiscriminately. One hub is the Dell docking station, another is the one provided with the laptop and the third is a 3rd party USB hub from HOOTOO. Issue present regardless of which devices im using.

- I am not using the 5G wifi and this happens when I use a wired connection as well.

- I have reproduced the problem without using a head set and only using the laptops built in speakers and microphone. I have also used other bluetooth ear buds, wired speakers and usb microphones. All still result in the problem.

- Id love to get a macbook at this point but since I have spent $2000+ on this laptop without the ability to return in and use that money to get a macbook I am stuck with this product. I am also in my 8th year of university finishing my masters so I am extremely broke. I feel like I am. TOS76>

. I can barely believe that yours works given the fact that I have had 3 systems that have the same problem. This is wild. Thank you for your suggestions, it is appreciated.

 

-

3 Apprentice

 • 

4.3K Posts

April 16th, 2023 13:00

Are you getting any indications in the Events tab of the different devices as to if and why they might be losing the connection?

Knowing if it only happened if plugged in or not is just a troubleshooting step.

Have you been able to tell if either the audio out or the Microphone in, is causing the problem?  

The 9520 is probably a modern standby system.  Is the 7590 also one of those?  Again, just another troubleshooting step.

Since Bluetooth headsets seem to go around Waves, it is probably not responsible.

The audio on recent systems changed from a Realtek Audio to a Realtek USB Audio version, which puts the audio through the PCIe bus.  This change may be involved.

You might try not letting one of those apps have access to the Microphone, just to see if it makes a difference.

You stated you have used both Wi-Fi and Ethernet, but you did not mention what the Network Link Rate was with those options.

Hopefully, you and @Tesla1856 are talking apples to apples as far as the exact process you are using.

1 Rookie

 • 

25 Posts

April 16th, 2023 15:00

@Saltgrass I reproduced the issue and checked the events, however no new events were detected on the headphones or microphone. I am admittedly not super techy so maybe there is something I am missing, but im doing my best. 

- Im not sure about the link rate. If that means speed then I test an average of 100 mbps. 

- It impacts both the input and outputs. as far as which one is causing the problem, I cant say for sure. I really dont know whats causing the problem. 

- This PCIe Bus thing is something ill look into.

- I feel like I laid out the process relatively well for anyone who would want to try it. so i am thinking @Tesla1856 should be able to get an accurate test of whether their unit is doing the same thing, but they report it isnt, so idk. 

Maybe some component they are using in these are garbage and lots of them dont work but some do. My head is twisted right up with this at this point. Realistically all of this should just work fine out of the box. I am not doing anything weird or overly demanding. just want to be able to use discord while I game..

I recall playing rocket league and just using the in game voice chat function and it was getting all messed up as well, so thats without discord or zoom running. it just seems to not be able to route the inputs and outputs properly. 

When I do the process mentioned in the earlier post, I notice that the computer lags or freezes up for a quick second when i change videos and it is at that moment of lag that the zoom warning comes up saying that it cannto detect my speakers or microphone. it seems like a process is happening that has its wires crossed or something.

8 Wizard

 • 

17K Posts

April 16th, 2023 19:00


@TStien wrote:

1. I find it hard to only use windows drivers as the support assist app is handy for keeping my computer up to date,

2. I have used 3 different usb hubs and all 3 USB-C ports on the laptop and reproduced the issue indiscriminately. One hub is the Dell docking station, another is the one provided with the laptop and the third is a 3rd party USB hub from HOOTOO. Issue present regardless of which devices im using.

 


1. The whole point of the Microsoft version clean-install is to NOT install Support-Assist or any Dell drivers and/or Apps. Windows-Update has everything you needs to run Windows and Apps.

Support-Assist (and it's associated Processes and Services) are known to drag machines down.

You can also try disabling Core-Isolation.

2. Interesting ... but not what I recommended.

 

 

3 Apprentice

 • 

4.3K Posts

April 16th, 2023 20:00

The 100 Mbps down may be a little low for what you are doing, since the link speed may be higher than the actual speed.  The upload speeds, microphone, are usually quite a bit less.

Something you might do, leave the Task Manager on and watch the network upload and download speeds to see if they approach what you might expect to be your advertised speeds.  

You may be able to pick up any glitches and tie them to some event.

If you are getting a warning, the software is watching the connection and noticing a problem, which causes some type of alternation of your configuration.  

Something I was wondering about was, were you using the microphone for more than one connection at the same time.  I know you can hear more than one input, but the microphone may not be able to handle that.

1 Rookie

 • 

25 Posts

April 17th, 2023 07:00

My apologies for complaining here, I appreciate your suggestions and help. I am losing my mind at this point. I am not doing anything differently here than what I have done on every computer I have ever had or that anyone that I know does with their computers. I just want to use discord. I promise I can pick any computer off the shelf right now and use it to do what I am trying to do. I just want to play a video game while using discord this is something simple that not a single person I know has had any issue with. I am not equipped to figure this out, but I am resistant to believing that a $2500 flagship laptops cant do the exact thing I can do on any computer I have ever tried, including my surface pro 4 that is like 6-7 years old and sitting next to me right now. The only variable in this entire situation that has changed is the computer. I can understand if there is a setting, software or hardware that is causing a problem, but the idea that my internet is causing this issue or that I am asking the computer to do something computers cant do is immediately not the case based on the ability to do it on any other computer in the same house using the same process,, connections and devices. I am not knowledgeable enough to deal with the complexities of the internal components and processes of the computer, but this should not be an issue in the first place, its basic voice chat stuff. Every work from home person over covid was able to do this same thing (including myself, until I got this particular model of laptop). I have been trying to figure this out since January, spending all of my free time on the phone with tech support or with anyone who is willing to try and help. I am so frustrated at this point. If it can be confirmed that this is not the case with other 9520's I will get another replacement I guess. I am going to test the internet by monitoring task manager while reproducing the issue and I will l get a new clean windows install, just to be sure. I am not missing something basic, but I believe there is something more going on here. something far beyond my ability to find. Sorry for any attitude that is coming through here.

8 Wizard

 • 

17K Posts

April 18th, 2023 09:00


@TStien wrote:

I am losing my mind at this point. 

I am not knowledgeable enough to deal with the complexities of the internal components and processes of the computer,

I am so frustrated at this point. 


Yes, I understood that back when I entered thread and that is why I tried to help.

You seem to want to treat Windows laptop like an appliance or locked-down device (like an iPhone). It just doesn't work that way in Windows. Any drivers, Services and Processes, OS updates, background programs, App settings, external peripherals, etc ... can all affect the end-result operation of the computer.

Did you find the Core-Isolation setting? Is it on or off?.

No Events found!

Top