Start a Conversation


This post is more than 5 years old


April 14th, 2016 15:00

XtremIO RESTAPI changes after 4.0.2

One of my customer's recently upgraded to 4.0.2 which is when the snapshot commands started failing for one multi cluster XIO(it still works for single Xbrick)

Here is the URI and the data which used to work earlier. --data '{ "consistency-group-id":"C_HHCEPCCDBXX_PRDINSTVG", "snap-suffix":"snap_20160407-174324", "snapshot-set-name":"SS_C_HHCEPCCDBXX_PRDINSTVG_BKP_DLY2" }'

If I specifically mention the cluster name in the body of the request then it work's.

My question is that , since the XIO REST documentation support's the way it was originally working then why is the command failing when cluster name is not explicitly mentioned in the body ?

We have single Xbrick's in the lab so I am unable to test elsewhere other than the customer environment.

Suggestions ?

727 Posts

April 14th, 2016 21:00

If you have multiple clusters being managed by the same XMS, you would need to mention the Cluster name where you want the RestAPI call to act. This is mentioned in the RestAPI user guide also.

However, if you have only a single XtremIO cluster being managed by the XMS – providing the cluster name is optional.

Is this what you are asking?

12 Posts

April 14th, 2016 23:00


From "Page 10 XtremIO 4.0.2 RESTFUL API Guide"

Example: /api/json/v2/types/[object type]?cluster-name=xbrickdrm220 should work, but when I run this against the customer XIO Cluster's it still asks for the cluster ID.

SO in the end i again need to mention the cluster-name is the body of the request --data

'{ "cluster-name":"HHCXIOCLV02","consistency-group-id":"C_HHCEPCCDBXX_PRDINSTVG", "snap-suffix":"snap_20160407-174324", "snapshot-set-name":"SS_C_HHCEPCCDBXX_PRDINSTVG_BKP_DLY2" }'

64 Posts

April 16th, 2016 03:00

Are you suggesting this this worked in an earlier version of 4.0, but broke in 4.0.2? That fairly clearly shouldn't be the case...

This call should work with the cluster name being passed in the URL.  That's how I normally recommend using it, as that way you can be consistent across all calls - even those that are GET requests where there is no body (and thus it has to be in the URL).

I don't have a dual brick to test this on the at the moment, but I'll get one setup and confirm what you're saying.  If you can let me know what version it was working on that'll help me get a bug raised for it.

12 Posts

April 16th, 2016 04:00

It was 4.0.1 HF1.I engaged TECH Support 3 and they think that this is a bug.It has now been escalated to the Engineering.

Will keep this forum posted

No Events found!