hunterzzz

updated

9 years ago

H

hunterzzz

1 Rookie

•

4 Posts

3

19273

March 10th, 2013 07:00

WebUI login issues for Admin user

We have been working on setting up our primary Isilon cluster (12 NL400 nodes with OneFS 7.0.1.1) and have been having no issues until just recently. We prefer to use our active directory logins to perform administrative tasks in the WebUI but we realize this isnt working yet, so we have been using the admin user with its default password since we installed./configured the cluster. All of a sudden, beginning this past Wednesday evening we have been getting 'insufficient privilege' errors when logging in as admin in the WebUI, We receive an error message like the following when landing on the dashboard page:

Status

No privileges for this functionality

Your account does not include privileges for this specific OneFS functionality. Contact your systems administrator to request access.

and the URL changes to https://10.66.202.112:8080/OneFS#InsufficientPrivileges. Interestingly enough there are a couple of the pages we can get into without error, but most we cannot. Has anyone ever seen this for the admin user? I checked the user using 'isi auth user view admin' and the role using 'isi auth roles list -v --table-format' and compared those responses to our other cluster and they look the same. Does anyone have any other ideas or fixes??

Thanks in advance.

1 Attachment

  • soetingr

    1 Rookie

    •

    40 Posts

    8257

    0

    Posted March 12th, 2013 03:00

    This happened to us to. Please run the following on the node where you have the problem.

         webui_webware_ctl restart

    This resets the admin gui on a node.

  • hunterzzz

    1 Rookie

    •

    4 Posts

    8257

    1

    Posted March 12th, 2013 07:00

    Thank you for taking the time to respond, and you were right, that is what fixed the problem. What i ended up doing was running the following command:

    isi_for_array killall isi_webui_d

    this did a sighup and restarted the webui_d across all the nodes in the cluster and all is good.

    Thanks again!

  • cincystorage

    2 Intern

    •

    467 Posts

    8279

    1

    Posted April 15th, 2013 11:00

    Usually this happens because the software webui exists and doesn't lean up the pid file.  (Which is localted at /usr/local/www/webkit/appserver.pid) and that just needs to be cleaned up so the appserver can restart.

    I'm not sure if it has an auto restart feature or not,  but it would be nice... but this doesn't happen to often so i'm not overly annoyed..

  • 8279

    0

    Posted May 9th, 2017 04:00

    Hello, when i restart the webui service i got this error:

    IOError: [Errno 28] No space left on device

    /usr/local/sbin/webui_webware_ctl restart: webware failed to start

    can some help with this?

    thank you

  • Peter_Sero

    6 Operator

    •

    1169 Posts

    8279

    2

    Posted May 9th, 2017 07:00

    Hopefully it's not the cluster filesystem /ifs that is full...

    Troubleshoot a full pool or cluster

    Probably it's only a local disk overrunning, which is easier to fix:

    Troubleshoot Capacity Alerts on Node Operating System Partitions

    hth

    -- Peter

  • 8279

    0

    Posted May 10th, 2017 01:00

    Hi Peter, i did everything from pdf but without success

    this command newsyslog -R -a /var/log/ dont even work

    this is my status:

    Filesystem                  Size    Used  Avail Capacity  Mounted on

    /dev/mirror/root1          989M    492M    418M    54%      /

    devfs                          1.0K    1.0K      0B        100%    /dev

    /dev/mirror/var1            989M    989M    -79M    109%    /var

    /dev/mirror/var-crash    1.9G    22K    1.8G      0%      /var/crash

    /dev/md0                      62M    650K    56M      1%      /tmp/ufp

    OneFS                        125T    60T    63T      49%    /ifs

  • 8279

    1

    Posted May 10th, 2017 08:00

    Hey v.adam,

    If you ran the following command "find -x /var -type f -size +1M -print0 | xargs -0 ls -lh " then you should have a list of files that you can prune out of your /var directory. your /var/crash directory looks pretty full as well and there is usually dump files and core files that can be removed there as well to help free up space. Just be sure you dont remove the following system directories out of /var/crash

    /SupportIQ 

    /connectemc 

    /cto


    But you can remove core files and old log files all you want. otherwise I would open a chat with support over this issue full system partitions can cause node reboots and impacted workflows if not resolved.


    Regards,

  • Peter_Sero

    6 Operator

    •

    1169 Posts

    871

    1

    Posted May 10th, 2017 09:00

    In addition to D_Tracy's suggestions, we can try to rule out the case

    that already removed files which are kept in open status by some process

    still consume disk space. 

    du -sxh /var

    summarizes the disk space taken by all visible files in /var (excluding /var/crash).

    If this value is much lower than the number reported by df,

    then you have such 'dark matter', and if the related process(es)

    cannot be identified, the node would need to be rebooted.

    -- Peter

  • 871

    0

    Posted May 15th, 2017 03:00

    Hi, i started to delete old logs (i think) in /var/log, all files that end with .gz. i think they are old files. after that i have successful start of web service. if this is ok, i will continue with other files. i just need your confirmation that this is ok.

    Thank you.

  • sluetze

    2 Intern

    •

    300 Posts

    871

    0

    Posted May 15th, 2017 07:00

    yes this are old logfiles, which can be removed (if not needed for Administration purposes)