Announcement Banner
UNSOLVED

Adrnalnrsh

updated

16 years ago

A

Adrnalnrsh

41 Posts

0

40220

August 30th, 2010 17:00

Unable to add new virtual disk after server reboot (kernel upgrade)

I can still see all of the previous storage (luns) assigned however I cannot see the new virtual disk I assigned to this host. 

#tail -F /var/log/messages

kernel: scsi 6:0:0:0: Unexpected response from lun 1 while scanning, scan aborted

#dmesg

scsi 6:0:0:0: Unexpected response from lun 1 while scanning, scan aborted

scsi 6:0:0:0: Unexpected response from lun 1 while scanning, scan aborted

end_request: I/O error, dev sdd, sector 32

Buffer I/O error on device sdd, logical block 4

Buffer I/O error on device sdd, logical block 5

Buffer I/O error on device sdd, logical block 6

Buffer I/O error on device sdd, logical block 7

Buffer I/O error on device sdd, logical block 8

 

#fdisk -l

Disk /dev/sdd: 20 MB, 20971520 bytes

64 heads, 32 sectors/track, 20 cylinders

Units = cylinders of 2048 * 512 = 1048576 bytes

 

Disk /dev/sdd doesn't contain a valid partition table 

One thing I noticed was two modules missing. 

#lsmod | grep mpp

mppVhba               162016  0 

mppUpper              143692  1 mppVhba

scsi_mod              196953  15 mppVhba,mppUpper,usb_storage,mptctl,scsi_dh,sr_mod,sg,mptspi,scsi_transport_spi,libata,mptsas,mptscsih,scsi_transport_sas,megaraid_sas,sd_mod

 

#cat /etc/redhat-release

CentOS release 5.5 (Final)

#uname -r

2.6.18-194.3.1.el5

 

 

#dkms status

linuxrdac, 09.03.0C06.0030, 2.6.18-194.3.1.el5, x86_64: installed 

 

#hot_add

Starting new devices re-scan...

scan mptsas HBA host /sys/class/scsi_host/host1...

no new device found

run /usr/sbin/mppUtil -s busscan...

scan mpp virtual host /sys/class/scsi_host/host6...

no new virtual device found

/usr/sbin/hot_add is completed.

  • Dev Mgr

    6 Operator

    •

    9308 Posts

    •

    3 Points

    1168

    0

    Posted August 31st, 2010 08:00

    If you check the MD3000/MD3000i support matrix, Red Hat 5.5 isn't supported (2.6.18-194 is the Red Hat 5.5 kernel). This kernel has been out several months without Dell adding it to the support matrix. This probably means that that kernel won't work (properly) with the RDAC driver that's currently available.

    I'd suggest you

    - revert to a supported kernel and stay on that till Dell comes out with a newer resource CD (in combination with an updated support matrix that shows that RHEL 5.5 is supported) and update the RDAC driver in combination with updating the kernel

    Or, if failover/redundancy isn't too important;

    - you reboot the server to see if that finds the disk, and accept that if a failure were to occur, you may not have failover

  • Adrnalnrsh

    41 Posts

    1168

    0

    Posted November 15th, 2010 10:00

    Does anyone know if 5.5 is supported yet?

  • Adrnalnrsh

    41 Posts

    1168

    0

    Posted November 15th, 2010 12:00

    Ok, I have the following firmware.

    07.35.22.61 - is this second gen? Don't see anything actually saying it is, but it would seem so.

    Do I need to install an updated driver then to make 5.5 work and can this be done online or should I schedule downtime? 

     

     

  • Adrnalnrsh

    41 Posts

    1168

    0

    Posted November 15th, 2010 12:00

    Ok, I see that this is second gen, so my only question is about the drivers?

  • mrokkam

    154 Posts

    1168

    0

    Posted November 15th, 2010 12:00

    RHEL 5.5 appears to be supported with 2nd gen firmware

    http://support.dell.com/support/edocs/systems/md3000i/en/

    Check out the support matrix above.

  • Dev Mgr

    6 Operator

    •

    9308 Posts

    •

    3 Points

    1168

    0

    Posted November 15th, 2010 13:00

    You'll want to verify that you have the latest DRAC driver installed (don't try to use linux native multipathing). You can check the latest version on the CD/ISO in the linux\RPMS\rh5 folder (compare the installed version to the version number in the filename).

  • Adrnalnrsh

    41 Posts

    1168

    0

    Posted November 15th, 2010 14:00

    Installed rdac

    linuxrdac-09.03.0C06.0030-1dkms

     

     

    On cd

    linuxrdac-09.03.0C06.0234-1dkms

     

    Should I just do a rpm -Uvh ? then run hot_add?

  • Adrnalnrsh

    41 Posts

    1168

    0

    Posted November 15th, 2010 15:00

    Also will I need to restart the host?

  • mrokkam

    154 Posts

    1168

    0

    Posted November 16th, 2010 08:00

    the simplest method would be to use the RCD and run the install script. This will ensure that all the correct versions and supporting modules are installed.

    I do believe that you have to reboot the host after install but I am not sure....wouldn't hurt to do it :-D

  • Adrnalnrsh

    41 Posts

    176

    0

    Posted November 16th, 2010 09:00

    Thanks will do.