Announcement Banner

SueF1

updated

2 years ago

S

SueF1

1 Rookie

•

39 Posts

0

1763

September 25th, 2014 12:00

soft-grace syntax

Hello,

Can someone tell me the CLI syntax to specify 9999 days for the --soft-grace option of the isi quota quotas command?  I've tried

isi quota quotas modify --path --type directory --soft-grace 9999, but it doesn't modify the duration.

The CLI guide lists this, but I have to clue how to interpret it:

Specify in the following format.

in the following format:

- -

[T : [: ]]

as one of the following values.

Y — Specifies years

M — Specifies months

W — Specifies weeks

D — Specifies days

h — Specifies hours

s — Specifies seconds

Regards,

Sue Flood

  • dynamox

    11 Legend

    •

    20419 Posts

    •

    87439 Points

    946

    0

    Posted September 25th, 2014 13:00

    isi quota quotas create --container=yes --enforced yes --hard-threshold=100G --include-snapshots=no --soft-threshold=90G --soft-grace=9999D --type=directory --path /ifs/data/n2isilonpoc/ts/documents

  • SueF1

    1 Rookie

    •

    39 Posts

    943

    0

    Posted September 25th, 2014 12:00

    I get the following error:

    Unknown time unit d

    Sue Flood

  • SueF1

    1 Rookie

    •

    39 Posts

    947

    0

    Posted September 25th, 2014 12:00

    Tried that and it appeared to work (no error returned), but it did not make the modification. That directory still has a grace period of 7 days (1W).

    Sue Flood

  • dynamox

    11 Legend

    •

    20419 Posts

    •

    87439 Points

    944

    0

    Posted September 25th, 2014 12:00

    try 27Y4M3W3D instead of 9999D

  • SueF1

    1 Rookie

    •

    39 Posts

    943

    0

    Posted September 25th, 2014 12:00

    Here is the whole output:

    1. isi quota quotas modify --path /ifs/NFS/EDR111 --soft-grace=9999d

    Unknown time unit d

    Sue Flood

    Technology Consultant, FDA Account

    US Public Sector

    HP Enterprise Services

    sue.flood@hp.com

    T +1 704 549 5490

    M +1 704 634 9866

    Hewlett-Packard Company

    Suite 200W

    10101 Claude Freeman Dr.

    Charlotte, NC 28262

    USA

  • dynamox

    11 Legend

    •

    20419 Posts

    •

    87439 Points

    943

    1

    Posted September 25th, 2014 12:00

    --soft-grace=9999D

  • dynamox

    11 Legend

    •

    20419 Posts

    •

    87439 Points

    946

    0

    Posted September 25th, 2014 13:00

    change modify instead of create

  • SueF1

    1 Rookie

    •

    39 Posts

    946

    0

    Posted September 25th, 2014 14:00

    1. isi quota quotas modify --container=yes --enforced yes --hard-threshold=1.4648T --include-snapshots=no --soft-threshold=1.3916T --soft-grace=9999d --type=directory --path /ifs/NFS/CHDC/INTRANET/PRE/DCTM/492/EDR114

    Unknown time unit d

    What am I doing wrong?

    Sue Flood

  • peglarr

    2 Intern

    •

    99 Posts

    946

    1

    Posted September 25th, 2014 14:00

    SUE,

    it is is right there in the guide...

    use D (upper case D), not lower case.  Lower case fails with the error you see.  Upper case works.

    try it...

    cheers

    Rob

  • 331

    0

    Posted September 26th, 2014 06:00

    The fact that it's case-sensitive really is annoying...

    Additionally, if you're looking to set a soft-grace to 9999 days, that's probably not what you want anyway.  Look at the advisory threshold which can send out the email alerts but never prevent a write.  There is no grace period associated with the advisory thresholds.